summaryrefslogtreecommitdiff
path: root/media-gfx/opencsg/opencsg-1.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/opencsg/opencsg-1.4.2-r1.ebuild')
-rw-r--r--media-gfx/opencsg/opencsg-1.4.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/opencsg/opencsg-1.4.2-r1.ebuild b/media-gfx/opencsg/opencsg-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..faa23f4458b3
--- /dev/null
+++ b/media-gfx/opencsg/opencsg-1.4.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+MY_P="OpenCSG-${PV}"
+DESCRIPTION="The Constructive Solid Geometry rendering library"
+HOMEPAGE="http://www.opencsg.org"
+SRC_URI="http://www.opencsg.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/glew:0="
+DEPEND="${RDEPEND}
+ dev-qt/qtcore:5
+ media-libs/mesa[gles2]
+"
+
+S="${WORKDIR}/${MY_P}/src"
+
+PATCHES=(
+ "${FILESDIR}/${P}-includepath.patch"
+)
+
+src_prepare() {
+ default
+
+ # removes duplicated headers
+ rm -r ../glew || die "failed to remove bundled glew"
+}
+
+src_configure() {
+ eqmake5 src.pro INSTALLDIR="/usr" LIBDIR="$(get_libdir)"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}