summaryrefslogtreecommitdiff
path: root/media-gfx/netgen/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/netgen/files')
-rw-r--r--media-gfx/netgen/files/netgen-6.2.2204-use-external-pybind11.patch30
-rw-r--r--media-gfx/netgen/files/netgen-6.2.2301-find-libjpeg-turbo-library.patch (renamed from media-gfx/netgen/files/netgen-6.2.2204-find-libjpeg-turbo-library.patch)10
-rw-r--r--media-gfx/netgen/files/netgen-6.2.2301-fix-nullptr-deref-in-archive.patch31
3 files changed, 36 insertions, 35 deletions
diff --git a/media-gfx/netgen/files/netgen-6.2.2204-use-external-pybind11.patch b/media-gfx/netgen/files/netgen-6.2.2204-use-external-pybind11.patch
deleted file mode 100644
index ef11c8b0821a..000000000000
--- a/media-gfx/netgen/files/netgen-6.2.2204-use-external-pybind11.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From c3c55fe646ad6934e429edd080aceae54260551c Mon Sep 17 00:00:00 2001
-From: Bernd Waibel <waebbl-gentoo@posteo.net>
-Date: Sun, 30 Oct 2022 14:50:48 +0100
-Subject: [PATCH] use external pybind11
-
-Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -302,7 +302,7 @@ else()
- endif()
-
- if (USE_PYTHON)
-- add_subdirectory(external_dependencies/pybind11)
-+ find_package(pybind11)
- find_path(PYBIND_INCLUDE_DIR pybind11/pybind11.h HINTS ${PYTHON_INCLUDE_DIR})
- if( PYBIND_INCLUDE_DIR )
- message(STATUS "Found Pybind11: ${PYBIND_INCLUDE_DIR}")
---- a/cmake/SuperBuild.cmake
-+++ b/cmake/SuperBuild.cmake
-@@ -154,7 +154,6 @@ endif()
- #######################################################################
- if (USE_PYTHON)
- find_path(PYBIND_INCLUDE_DIR pybind11/pybind11.h PATHS ${CMAKE_CURRENT_SOURCE_DIR}/external_dependencies/pybind11/include NO_DEFAULT_PATH)
-- set(NG_INSTALL_PYBIND ON)
- if( NOT PYBIND_INCLUDE_DIR )
- # if the pybind submodule is missing, try to initialize and update all submodules
- execute_process(COMMAND git submodule update --init --recursive WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
---
-2.38.1
-
diff --git a/media-gfx/netgen/files/netgen-6.2.2204-find-libjpeg-turbo-library.patch b/media-gfx/netgen/files/netgen-6.2.2301-find-libjpeg-turbo-library.patch
index c45f5a4e4bdb..3b01321f7ced 100644
--- a/media-gfx/netgen/files/netgen-6.2.2204-find-libjpeg-turbo-library.patch
+++ b/media-gfx/netgen/files/netgen-6.2.2301-find-libjpeg-turbo-library.patch
@@ -1,6 +1,6 @@
-From 39160b692fd051f2638f1a6e1df38eb616b6d6cb Mon Sep 17 00:00:00 2001
+From d8a654a61452c39e3e611493ad70b8c6e818130e Mon Sep 17 00:00:00 2001
From: Bernd Waibel <waebbl-gentoo@posteo.net>
-Date: Sun, 30 Oct 2022 16:09:43 +0100
+Date: Wed, 15 Feb 2023 12:28:00 +0100
Subject: [PATCH] find libjpeg-turbo library
Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
@@ -10,8 +10,8 @@ Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
vssolution.cpp
visualpkg.cpp
)
--target_link_libraries( nggui PUBLIC "$<BUILD_INTERFACE:netgen_python>" ${MPI_CXX_LIBRARIES} ${OPENGL_LIBRARIES} )
-+target_link_libraries( nggui PUBLIC "$<BUILD_INTERFACE:netgen_python>" ${MPI_CXX_LIBRARIES} ${OPENGL_LIBRARIES} ${JPEG_LIBRARIES} )
+-target_link_libraries( nggui PUBLIC "$<BUILD_INTERFACE:netgen_python>" ${MPI_CXX_LIBRARIES} ${OPENGL_LIBRARIES} nglib)
++target_link_libraries( nggui PUBLIC "$<BUILD_INTERFACE:netgen_python>" ${MPI_CXX_LIBRARIES} ${OPENGL_LIBRARIES} ${JPEG_LIBRARIES} nglib)
install(FILES
meshdoc.hpp mvdraw.hpp visual_api.hpp
@@ -30,5 +30,5 @@ Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
install(TARGETS nglib netgen_cgns ${NG_INSTALL_DIR})
--
-2.38.1
+2.39.1
diff --git a/media-gfx/netgen/files/netgen-6.2.2301-fix-nullptr-deref-in-archive.patch b/media-gfx/netgen/files/netgen-6.2.2301-fix-nullptr-deref-in-archive.patch
new file mode 100644
index 000000000000..b05d71221ca5
--- /dev/null
+++ b/media-gfx/netgen/files/netgen-6.2.2301-fix-nullptr-deref-in-archive.patch
@@ -0,0 +1,31 @@
+https://github.com/NGSolve/netgen/pull/123/commits/5ee4e43393936ab4c00feb58c48bc3a10e6bcbdb
+
+From 76276c5a3b0e70b27d44f7ce0a3ea064b23909da Mon Sep 17 00:00:00 2001
+From: Christopher Montgomery <monty@xiph.org>
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sun, 19 Feb 2023 12:18:12 +0100
+Subject: [PATCH] fix nullptr deref in archive
+
+Hardened toolchains (eg, mainline Fedora) no longer tolerate null
+derefs that were silently trapped/ignored in earlier versions. This
+eliminates a nullptr deref in archive.hpp that was failing several
+unit tests (and causing crashes) when trying to manipulate
+default-constructed archive objects.
+
+Adapted original patch according the comment in the PR.
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/libsrc/core/archive.hpp
++++ b/libsrc/core/archive.hpp
+@@ -225,7 +225,7 @@ namespace ngcore
+ (*this) & size;
+ if(Input())
+ v.resize(size);
+- Do(&v[0], size);
++ Do(v.data(), size);
+ return (*this);
+ }
+
+--
+2.39.2
+