summaryrefslogtreecommitdiff
path: root/media-gfx/meshlab/meshlab-2016.12-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/meshlab/meshlab-2016.12-r4.ebuild')
-rw-r--r--media-gfx/meshlab/meshlab-2016.12-r4.ebuild66
1 files changed, 34 insertions, 32 deletions
diff --git a/media-gfx/meshlab/meshlab-2016.12-r4.ebuild b/media-gfx/meshlab/meshlab-2016.12-r4.ebuild
index bea9e2857554..505a20ab0b58 100644
--- a/media-gfx/meshlab/meshlab-2016.12-r4.ebuild
+++ b/media-gfx/meshlab/meshlab-2016.12-r4.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit qmake-utils
+inherit desktop qmake-utils
-DESCRIPTION="the open source system for processing and editing 3D triangular meshes"
+DESCRIPTION="The open source system for processing and editing 3D triangular meshes"
HOMEPAGE="http://www.meshlab.net"
VCG_VERSION="1.0.1"
SRC_URI="https://github.com/cnr-isti-vclab/meshlab/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/cnr-isti-vclab/vcglib/archive/v${VCG_VERSION}.tar.gz -> vcglib-${VCG_VERSION}.tar.gz
+ https://github.com/cnr-isti-vclab/vcglib/archive/v${VCG_VERSION}.tar.gz -> vcglib-${VCG_VERSION}.tar.gz
"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="-minimal"
+
DEPEND="dev-cpp/eigen:3
dev-cpp/muParser
dev-qt/qtcore:5
@@ -35,33 +36,34 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/meshlab-${PV}/src"
PATCHES=(
- "${FILESDIR}/${PV}/0001-set-shader-and-texture-paths.patch"
- #remove ot working plugins
- "${FILESDIR}/${PV}/remove-edit_mutualcorrs.patch"
- "${FILESDIR}/${PV}/remove-io_TXT.patch"
- #since structure synth doesn't seem to be compiling
- "${FILESDIR}/${PV}/0001-disable-filter-ssynth.patch"
- #this has been fixed in the tree
- "${FILESDIR}/${PV}/0001-disable-edit-quality.patch"
- #this causes segfaults
- "${FILESDIR}/${PV}/0001-disable-filter-layer.patch"
- #for when we use minimal
- "${FILESDIR}/${PV}/0001-compile-server.patch"
- "${FILESDIR}/${PV}/0001-use-external-lib3ds.patch"
- "${FILESDIR}/${PV}/0001-use-external-openctm.patch"
- "${FILESDIR}/${PV}/0001-use-external-muParser.patch"
- "${FILESDIR}/${PV}/0001-use-external-bzip.patch"
- "${FILESDIR}/${PV}/0001-use-external-jhead.patch"
- "${FILESDIR}/${PV}/0001-use-external-glew.patch"
- #cause gnu stack quickstart related qa
- "${FILESDIR}/${PV}/0001-remove-not-sane-plugins.patch"
- "${FILESDIR}/${PV}/${P}-fix-plugins-path.patch"
- "${FILESDIR}/${PV}/${P}-align1.patch"
- "${FILESDIR}/${PV}/${P}-align2.patch"
- "${FILESDIR}/${PV}/${P}-asString.patch"
- "${FILESDIR}/${PV}/${P}-qprintable.patch"
- "${FILESDIR}/${PV}/${P}-qt-includes.patch"
- )
+ "${FILESDIR}/${PV}/0001-set-shader-and-texture-paths.patch"
+ #remove ot working plugins
+ "${FILESDIR}/${PV}/remove-edit_mutualcorrs.patch"
+ "${FILESDIR}/${PV}/remove-io_TXT.patch"
+ #since structure synth doesn't seem to be compiling
+ "${FILESDIR}/${PV}/0001-disable-filter-ssynth.patch"
+ #this has been fixed in the tree
+ "${FILESDIR}/${PV}/0001-disable-edit-quality.patch"
+ #this causes segfaults
+ "${FILESDIR}/${PV}/0001-disable-filter-layer.patch"
+ #for when we use minimal
+ "${FILESDIR}/${PV}/0001-compile-server.patch"
+ "${FILESDIR}/${PV}/0001-use-external-lib3ds.patch"
+ "${FILESDIR}/${PV}/0001-use-external-openctm.patch"
+ "${FILESDIR}/${PV}/0001-use-external-muParser.patch"
+ "${FILESDIR}/${PV}/0001-use-external-bzip.patch"
+ "${FILESDIR}/${PV}/0001-use-external-jhead.patch"
+ "${FILESDIR}/${PV}/0001-use-external-glew.patch"
+ #cause gnu stack quickstart related qa
+ "${FILESDIR}/${PV}/0001-remove-not-sane-plugins.patch"
+ "${FILESDIR}/${PV}/${P}-fix-plugins-path.patch"
+ "${FILESDIR}/${PV}/${P}-align1.patch"
+ "${FILESDIR}/${PV}/${P}-align2.patch"
+ "${FILESDIR}/${PV}/${P}-asString.patch"
+ "${FILESDIR}/${PV}/${P}-qprintable.patch"
+ "${FILESDIR}/${PV}/${P}-qt-includes.patch"
+ "${FILESDIR}/${PV}/${P}-qt-5.15.patch"
+)
src_prepare() {
mv "${WORKDIR}/vcglib-${VCG_VERSION}" "${WORKDIR}/vcglib" || die "vcglib mv failed"
@@ -93,7 +95,7 @@ src_configure() {
src_install() {
dobin distrib/{meshlab,meshlabserver}
- dolib distrib/libcommon.so.1.0.0
+ dolib.so distrib/libcommon.so.1.0.0
dosym libcommon.so.1.0.0 /usr/$(get_libdir)/libcommon.so.1
dosym libcommon.so.1 /usr/$(get_libdir)/libcommon.so
exeinto /usr/$(get_libdir)/meshlab/plugins