summaryrefslogtreecommitdiff
path: root/media-gfx/luminance-hdr/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/luminance-hdr/files')
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-cmake.patch22
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-docs.patch15
-rw-r--r--media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-no-git.patch15
3 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-cmake.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-cmake.patch
new file mode 100644
index 000000000000..5564ebadc951
--- /dev/null
+++ b/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-cmake.patch
@@ -0,0 +1,22 @@
+--- a/CMakeLists.txt 2019-06-09 21:18:38.000000000 +0200
++++ b/CMakeLists.txt 2019-09-15 23:53:19.496802424 +0200
+@@ -5,19 +5,6 @@
+ CMAKE_POLICY(SET CMP0053 NEW)
+ PROJECT("Luminance HDR")
+
+-string(TOLOWER ${CMAKE_BUILD_TYPE} LOWERCASE_CMAKE_BUILD_TYPE)
+-if(LOWERCASE_CMAKE_BUILD_TYPE MATCHES "^(debug|release|relwithdebinfo|minsizerel)$")
+- message(STATUS "CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
+-else()
+- message(FATAL_ERROR "Invalid value for CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}\n"
+- "CMAKE_BUILD_TYPE should be one of:\nDebug, Release, RelWithDebInfo, MinSizeRel")
+-endif()
+-
+-if(LOWERCASE_CMAKE_BUILD_TYPE MATCHES "^(release|minsizerel)$")
+- message(STATUS "Adding definitions: -DQT_NO_DEBUG_OUTPUT")
+- add_definitions("-DQT_NO_DEBUG_OUTPUT")
+-endif()
+-
+ # assume built-in pthreads on MacOS
+ IF(APPLE)
+ enable_language(CXX)
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-docs.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-docs.patch
new file mode 100644
index 000000000000..982c7ebfac21
--- /dev/null
+++ b/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-docs.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2019-06-09 21:18:38.000000000 +0200
++++ b/CMakeLists.txt 2019-09-15 23:43:41.005292354 +0200
+@@ -413,12 +413,6 @@
+ INSTALL(FILES ${CMAKE_SOURCE_DIR}/program-icons/luminance-hdr.png DESTINATION share/icons/hicolor/48x48/apps) # icon
+ INSTALL(FILES ${CMAKE_SOURCE_DIR}/net.sourceforge.qtpfsgui.LuminanceHDR.desktop DESTINATION share/applications) #desktop entry
+ INSTALL(FILES ${CMAKE_SOURCE_DIR}/net.sourceforge.qtpfsgui.LuminanceHDR.appdata.xml DESTINATION share/appdata) #appstream
+- INSTALL(FILES
+- ${CMAKE_SOURCE_DIR}/AUTHORS
+- ${CMAKE_SOURCE_DIR}/README.md
+- ${CMAKE_SOURCE_DIR}/LICENSE
+- ${CMAKE_SOURCE_DIR}/Changelog
+- DESTINATION share/luminance-hdr/doc) #info files
+ INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/help DESTINATION share/luminance-hdr) # help directory
+ INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/hdrhtml DESTINATION share/luminance-hdr) # hdrhtml directory
+ # Microsoft Windows
diff --git a/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-no-git.patch b/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-no-git.patch
new file mode 100644
index 000000000000..95fc805e83f9
--- /dev/null
+++ b/media-gfx/luminance-hdr/files/luminance-hdr-2.6.0-no-git.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2019-06-09 21:18:38.000000000 +0200
++++ b/CMakeLists.txt 2019-09-15 23:41:24.684413834 +0200
+@@ -103,11 +103,7 @@
+ set(LIBS ${LIBS} ${QT_QTWEBKIT_LIBRARIES})
+ endif()
+
+-FIND_PACKAGE(Git)
+-IF(GIT_FOUND)
+- include(GetGitRevisionDescription)
+- get_git_head_revision(GIT_REFSPEC GIT_SHA1)
+-ENDIF()
++SET(GIT_SHA1 "-- Gentoo build --")
+
+ IF(WIN32)
+