summaryrefslogtreecommitdiff
path: root/media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild')
-rw-r--r--media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild b/media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild
new file mode 100644
index 000000000000..8ff1d8261abe
--- /dev/null
+++ b/media-gfx/jpeginfo/jpeginfo-1.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Prints information and tests integrity of JPEG/JFIF files"
+HOMEPAGE="https://www.kokkonen.net/tjko/projects.html"
+SRC_URI="https://www.kokkonen.net/tjko/src/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="media-libs/libjpeg-turbo:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README
+}