summaryrefslogtreecommitdiff
path: root/media-gfx/jp2a/jp2a-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jp2a/jp2a-1.1.1.ebuild')
-rw-r--r--media-gfx/jp2a/jp2a-1.1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-gfx/jp2a/jp2a-1.1.1.ebuild b/media-gfx/jp2a/jp2a-1.1.1.ebuild
new file mode 100644
index 000000000000..6b66aafdfe5b
--- /dev/null
+++ b/media-gfx/jp2a/jp2a-1.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="JPEG image to ASCII art converter"
+HOMEPAGE="https://github.com/Talinx/jp2a/"
+SRC_URI="https://github.com/Talinx/jp2a/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="curl"
+
+# TODO: restore ncurses support?
+# See https://github.com/gentoo/gentoo/pull/24218#issuecomment-1043795319
+RDEPEND="virtual/jpeg
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable curl)
+}