summaryrefslogtreecommitdiff
path: root/media-gfx/jhead/jhead-3.00-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jhead/jhead-3.00-r2.ebuild')
-rw-r--r--media-gfx/jhead/jhead-3.00-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/jhead/jhead-3.00-r2.ebuild b/media-gfx/jhead/jhead-3.00-r2.ebuild
new file mode 100644
index 000000000000..4003550535b0
--- /dev/null
+++ b/media-gfx/jhead/jhead-3.00-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare(){
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ eapply "${FILESDIR}/${PN}-2.90-mkstemp_respect_flags.patch"
+ cp "${FILESDIR}/Makefile" makefile || die
+ eapply_user
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ docinto html
+ dodoc *.html
+ doman ${PN}.1
+ doheader ${PN}.h
+ dolib.so lib${PN}.so*
+}