summaryrefslogtreecommitdiff
path: root/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild')
-rw-r--r--media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild47
1 files changed, 15 insertions, 32 deletions
diff --git a/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild
index 380f3d1e59ea..e876f9536887 100644
--- a/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild
+++ b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit rpm versionator multilib
+inherit rpm
-MY_PV="$(get_version_component_range 1-3)"
-MY_PVR="$(replace_version_separator 3 -)"
+MY_PV="$(ver_cut 1-3)"
+MY_PVR="$(ver_rs 3 -)"
DESCRIPTION="Epson Perfection V500 scanner plugin for SANE 'epkowa' backend"
HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
@@ -14,19 +14,16 @@ SRC_URI="
x86? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}/${MY_PV}/${PN}-${MY_PVR}.i386.rpm )
amd64? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}/${MY_PV}/${PN}-${MY_PVR}.x86_64.rpm )
"
+S="${WORKDIR}"
LICENSE="AVASYS"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-
DEPEND=">=media-gfx/iscan-2.21.0
!!<media-gfx/iscan-plugin-gt-x770-2.1.2.1-r2"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
-
QA_PREBUILT="/opt/iscan/esci/libesint7C.so*"
src_configure() { :; }
@@ -44,46 +41,32 @@ src_install() {
doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
}
-pkg_setup() {
- basecmds=(
- "iscan-registry --COMMAND interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
- )
-}
-
pkg_postinst() {
elog
elog "Firmware file esfw41.bin for Epson Perfection V500"
- elog "has been installed in /usr/share/iscan."
+ elog "has been installed in ${EROOT}/usr/share/iscan."
elog
- [[ -n ${REPLACING_VERSIONS} ]] && return
+ [[ -n "${REPLACING_VERSIONS}" ]] && return
# Needed for scanner to work properly.
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/add}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --add interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin || die
else
ewarn "Unable to register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/add}"
- done
+ ewarn "iscan-registry --add interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
fi
}
pkg_prerm() {
- [[ -n ${REPLACED_BY_VERSION} ]] && return
+ [[ -n "${REPLACED_BY_VERSION}" ]] && return
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/remove}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --remove interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin || die
else
ewarn "Unable to de-register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/remove}"
- done
+ ewarn "iscan-registry --remove interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
fi
}