summaryrefslogtreecommitdiff
path: root/media-gfx/inkscape/inkscape-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/inkscape/inkscape-1.3.2.ebuild')
-rw-r--r--media-gfx/inkscape/inkscape-1.3.2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-gfx/inkscape/inkscape-1.3.2.ebuild b/media-gfx/inkscape/inkscape-1.3.2.ebuild
index ca758524da42..a59e5ee19170 100644
--- a/media-gfx/inkscape/inkscape-1.3.2.ebuild
+++ b/media-gfx/inkscape/inkscape-1.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,6 +8,9 @@ PYTHON_REQ_USE="xml(+)"
MY_P="${P/_/}"
inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
+DESCRIPTION="SVG based generic vector-drawing program"
+HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
+
if [[ ${PV} = 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
@@ -16,8 +19,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-DESCRIPTION="SVG based generic vector-drawing program"
-HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
@@ -104,7 +106,9 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-cpp/gtest )
"
-S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-libxml2-2.12.patch
+)
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp