summaryrefslogtreecommitdiff
path: root/media-gfx/hydrus/hydrus-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/hydrus/hydrus-9999.ebuild')
-rw-r--r--media-gfx/hydrus/hydrus-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-gfx/hydrus/hydrus-9999.ebuild b/media-gfx/hydrus/hydrus-9999.ebuild
index e447f565f37b..072c47dfe381 100644
--- a/media-gfx/hydrus/hydrus-9999.ebuild
+++ b/media-gfx/hydrus/hydrus-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="sqlite"
DOCS_BUILDER=mkdocs
@@ -18,8 +18,12 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/hydrusnetwork/hydrus.git"
+ SRC_URI="https://github.com/vaartis/hydrus/commit/106a55b3aca945d047685eb53bd1d2aa8b8a7c50.diff -> ${PN}-3.11-test-fixes.patch"
else
- SRC_URI="https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/hydrusnetwork/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vaartis/hydrus/commit/106a55b3aca945d047685eb53bd1d2aa8b8a7c50.diff -> ${PN}-3.11-test-fixes.patch
+ "
KEYWORDS="~amd64"
fi
@@ -58,7 +62,6 @@ RDEPEND="
dev-python/twisted[${PYTHON_USEDEP}]
media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
media-video/ffmpeg
- media-video/mpv[libmpv,${PYTHON_USEDEP}]
>=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
@@ -76,6 +79,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/userpath-in-local-share.patch"
+ "${DISTDIR}/${PN}-3.11-test-fixes.patch"
)
src_prepare() {