summaryrefslogtreecommitdiff
path: root/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch')
-rw-r--r--media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch b/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
new file mode 100644
index 000000000000..b162ca9aa6f9
--- /dev/null
+++ b/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
@@ -0,0 +1,18 @@
+https://src.fedoraproject.org/rpms/graphite2/raw/41fb7c104c8f9293254abaa91bbda1daafb458cd/f/graphite-arm-nodefaultlibs.patch
+https://bugs.gentoo.org/829690
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -120,11 +120,7 @@
+ if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
+ else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+- if (GRAPHITE2_SANITIZERS)
+- target_link_libraries(graphite2 c gcc_s)
+- else ()
+- target_link_libraries(graphite2 c gcc)
+- endif ()
++ target_link_libraries(graphite2 c gcc_s)
+ endif()
+ include(Graphite)
+ if (BUILD_SHARED_LIBS)
+