summaryrefslogtreecommitdiff
path: root/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch')
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch b/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
deleted file mode 100644
index a7e5804319d7..000000000000
--- a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-https://bugs.gentoo.org/829690
-
-See https://github.com/silnrsi/graphite/pull/44.
-
-Drop -nodefaultlibs:
-- graphite is written in C++ which makes avoiding libstdc++ (or libc++) a dubious
- goal;
-- this ends up breaking e.g. x86/musl because we need to inject -lssp_nonshared,
- but it wouldn't be surprising if it broke other exotic targets too.
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -105,7 +105,7 @@ set_target_properties(graphite2 PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
-@@ -135,7 +135,6 @@ endif()
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Darwin")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wimplicit-fallthrough -Wendif-labels -Wshadow -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -47,12 +47,12 @@ else (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
- set_target_properties(graphite2-base PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- set_target_properties(graphite2-file PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING${TELEMETRY}"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- endif()
-