summaryrefslogtreecommitdiff
path: root/media-gfx/graphicsmagick/graphicsmagick-1.3.37.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/graphicsmagick/graphicsmagick-1.3.37.ebuild')
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.37.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.37.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.37.ebuild
index 03a95689ff0e..85263d8a19fe 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.37.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.37.ebuild
@@ -57,6 +57,14 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.3.19-perl.patch
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_prepare() {
default
@@ -68,19 +76,14 @@ src_configure() {
use q16 && depth=16
use q32 && depth=32
- local openmp=disable
- if use openmp && tc-has-openmp ; then
- openmp=enable
- fi
-
local myeconfargs=(
- --${openmp}-openmp
--enable-largefile
--enable-shared
$(use_enable static-libs static)
$(use_enable debug prof)
$(use_enable debug gcov)
$(use_enable imagemagick magick-compat)
+ $(use_enable openmp)
$(use_with threads)
$(use_with dynamic-loading modules)
--with-quantum-depth=${depth}