summaryrefslogtreecommitdiff
path: root/media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch')
-rw-r--r--media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch b/media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch
new file mode 100644
index 000000000000..e97ef6bf6138
--- /dev/null
+++ b/media-gfx/gmic/files/gmic-3.0.1-openexr-3-imath.patch
@@ -0,0 +1,28 @@
+https://src.fedoraproject.org/rpms/gmic/raw/rawhide/f/gmic-openexr3.patch
+--- a/cmake/FindCImg.cmake
++++ b/cmake/FindCImg.cmake
+@@ -147,7 +147,10 @@ if(ENABLE_JPEG)
+ endif()
+
+ if(ENABLE_OPENEXR)
+- find_package(OpenEXR)
++ find_package(OpenEXR CONFIG)
++ if(NOT TARGET OpenEXR::OpenEXR)
++ find_package(OpenEXR)
++ endif()
+
+ if(OpenEXR_FOUND)
+ list(APPEND CLI_COMPILE_FLAGS "cimg_use_openexr")
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -307,8 +307,8 @@
+
+ # Enable native support of EXR image files, using the OpenEXR library.
+ # (http://www.openexr.com/)
+-OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(USR)/$(INCLUDE)/OpenEXR)
+-OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lIlmImf -lHalf)
++OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(USR)/$(INCLUDE)/OpenEXR -I$(USR)/$(INCLUDE)/Imath)
++OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lOpenEXR -lImath)
+
+ # Enable Fast Fourier Transforms, using the FFTW3 library.
+ # (http://www.fftw.org/)