summaryrefslogtreecommitdiff
path: root/media-gfx/gmic/files/gmic-3.0.0_ipa-sra.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gmic/files/gmic-3.0.0_ipa-sra.patch')
-rw-r--r--media-gfx/gmic/files/gmic-3.0.0_ipa-sra.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/media-gfx/gmic/files/gmic-3.0.0_ipa-sra.patch b/media-gfx/gmic/files/gmic-3.0.0_ipa-sra.patch
new file mode 100644
index 000000000000..04cfa560f193
--- /dev/null
+++ b/media-gfx/gmic/files/gmic-3.0.0_ipa-sra.patch
@@ -0,0 +1,16 @@
+A GCC-specific setting from years ago. gcc-9 quietly ignores it (the
+resulting binaries appear to be the same whether -fno-ipa-sra has been
+specified or not), clang fails on it as not recognised.
+Just get rid of it altogether.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -100,7 +100,7 @@
+ if(APPLE)
+ list(APPEND GMIC_CXX_COMPILE_FLAGS -mmacosx-version-min=10.8 -stdlib=libc++ -Wno-error=c++11-narrowing -Wc++11-extensions -fpermissive)
+ else()
+- list(APPEND GMIC_CXX_COMPILE_FLAGS -Wno-error=narrowing -fno-ipa-sra -fpermissive)
++ list(APPEND GMIC_CXX_COMPILE_FLAGS -Wno-error=narrowing -fpermissive)
+ endif()
+
+ if(NOT "${PRERELEASE_TAG}" STREQUAL "")