summaryrefslogtreecommitdiff
path: root/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch')
-rw-r--r--media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch b/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch
new file mode 100644
index 000000000000..a266fb94a996
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.10_fix_configure_GCC13_implicit_function_declarations.patch
@@ -0,0 +1,24 @@
+Gentoo issue: https://bugs.gentoo.org/899796
+
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1291,13 +1291,14 @@
+ #include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+- int main()
++ #include <stdlib.h>
++ int main(void)
+ {
+ int id;
+ char *shmaddr;
+- id = shmget (IPC_PRIVATE, 4, IPC_CREAT | 0600);
+- if (id == -1)
+- exit (2);
++ id = shmget (IPC_PRIVATE, 4, IPC_CREAT | 0600);
++ if (id == -1)
++ exit (2);
+ shmaddr = shmat (id, 0, 0);
+ shmctl (id, IPC_RMID, 0);
+ if ((char*) shmat (id, 0, 0) == (char*) -1)