summaryrefslogtreecommitdiff
path: root/media-gfx/fotocx/files/fotocx-24.20-documentation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fotocx/files/fotocx-24.20-documentation.patch')
-rw-r--r--media-gfx/fotocx/files/fotocx-24.20-documentation.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/fotocx/files/fotocx-24.20-documentation.patch b/media-gfx/fotocx/files/fotocx-24.20-documentation.patch
new file mode 100644
index 000000000000..977977dc1428
--- /dev/null
+++ b/media-gfx/fotocx/files/fotocx-24.20-documentation.patch
@@ -0,0 +1,25 @@
+diff -ur fotocx/Makefile fotocx.new/Makefile
+--- fotocx/Makefile 2024-04-01 04:14:12.000000000 -0500
++++ fotocx.new/Makefile 2024-04-03 12:07:21.271052526 -0500
+@@ -123,8 +123,7 @@
+ cp -f fotocx $(DESTDIR)$(BINDIR)
+ cp -f fotocx.desktop $(DESTDIR)$(MENUDIR)
+ cp -f -R doc/* $(DESTDIR)$(DOCDIR)
+- gzip -fk -9 man/fotocx.man
+- mv -f man/fotocx.man.gz $(DESTDIR)$(MANDIR)/fotocx.1.gz
++ cp man/fotocx.man $(DESTDIR)$(MANDIR)/fotocx.1
+ cp -f -R data $(DESTDIR)$(DATADIR)
+ cp -f -R images $(DESTDIR)$(DATADIR)
+ cp -f fotocx.png $(DESTDIR)$(ICONDIR)
+diff -ur fotocx/zfuncs.cc fotocx.new/zfuncs.cc
+--- fotocx/zfuncs.cc 2024-04-01 04:14:12.000000000 -0500
++++ fotocx.new/zfuncs.cc 2024-04-03 12:07:59.543247027 -0500
+@@ -6125,7 +6125,7 @@
+
+ strncatv(zdatadir,199,zprefix,"/share/",zappname,"/data",null); // /prefix/share/appname/data
+ strncatv(zimagedir,199,zprefix,"/share/",zappname,"/images",null); // /prefix/share/appname/images
+- strncatv(zdocdir,199,zprefix,"/share/doc/",zappname,null); // /prefix/share/doc/appname
++ strncatv(zdocdir,199,zprefix,"/share/doc/",zappvers,null); // /prefix/share/doc/appname-version
+
+ ch_time = zstrdup(build_date_time,"zinitapp");
+ if (ch_time[4] == ' ') ch_time[4] = '0'; // replace month day ' d' with '0d'