summaryrefslogtreecommitdiff
path: root/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch')
-rw-r--r--media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch b/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch
new file mode 100644
index 000000000000..1aa0aec5163f
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -319,15 +319,7 @@
+ message(STATUS "Test-compilation of OpenCL programs is disabled.")
+ endif()
+
+-# we need jsonschema to check noiseprofiles.json
+-find_program(jsonschema_BIN jsonschema)
+-if(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+- message(STATUS "Missing jsonschema, problems in noiseprofiles.json might go unnoticed")
+- set(VALIDATE_JSON 0)
+-else(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+- message(STATUS "Found jsonschema")
+- set(VALIDATE_JSON 1)
+-endif(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
++set(VALIDATE_JSON 0)
+
+ # we need an xslt interpreter to generate preferences_gen.h and darktablerc
+ find_program(Xsltproc_BIN xsltproc)