summaryrefslogtreecommitdiff
path: root/media-gfx/blender/files
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/blender/files')
-rw-r--r--media-gfx/blender/files/blender-2.68-doxyfile.patch19
-rw-r--r--media-gfx/blender/files/blender-2.68-fix-install-rules.patch26
-rw-r--r--media-gfx/blender/files/blender-2.70-sse2.patch35
-rw-r--r--media-gfx/blender/files/blender-2.72-T42797.diff13
-rw-r--r--media-gfx/blender/files/blender-2.72b-fix-util_simd.patch10
-rw-r--r--media-gfx/blender/files/blender-2.72b-gcc6-fixes.patch126
6 files changed, 0 insertions, 229 deletions
diff --git a/media-gfx/blender/files/blender-2.68-doxyfile.patch b/media-gfx/blender/files/blender-2.68-doxyfile.patch
deleted file mode 100644
index c11c793fda97..000000000000
--- a/media-gfx/blender/files/blender-2.68-doxyfile.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 62308d9fc24bde22a50497816c44c8ca91f96f63
-Author: hasufell <hasufell@gentoo.org>
-Date: Fri Jul 19 18:36:34 2013 +0200
-
- remove hhc.exe reference
-
-diff --git a/doc/doxygen/Doxyfile b/doc/doxygen/Doxyfile
-index 397cc30..ac61756 100644
---- a/doc/doxygen/Doxyfile
-+++ b/doc/doxygen/Doxyfile
-@@ -1051,7 +1051,7 @@ CHM_FILE = blender.chm
- # the HTML help compiler (hhc.exe). If non-empty doxygen will try to run
- # the HTML help compiler on the generated index.hhp.
-
--HHC_LOCATION = "C:/Program Files (x86)/HTML Help Workshop/hhc.exe"
-+HHC_LOCATION =
-
- # If the GENERATE_HTMLHELP tag is set to YES, the GENERATE_CHI flag
- # controls if a separate .chi index file is generated (YES) or that
diff --git a/media-gfx/blender/files/blender-2.68-fix-install-rules.patch b/media-gfx/blender/files/blender-2.68-fix-install-rules.patch
deleted file mode 100644
index aa8ecc9f6174..000000000000
--- a/media-gfx/blender/files/blender-2.68-fix-install-rules.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-commit 94eed33f878e35a8c7b69b0c23b3b30026460f33
-Author: hasufell <hasufell@gentoo.org>
-Date: Fri Jul 19 18:50:08 2013 +0200
-
- remove stupid uninstall snippet
-
- whoever coded this... it is dangerous
- uninstall methods have NO PLACE in install rules
-
-diff --git a/source/creator/CMakeLists.txt b/source/creator/CMakeLists.txt
-index c84d944..2b9bf46 100644
---- a/source/creator/CMakeLists.txt
-+++ b/source/creator/CMakeLists.txt
-@@ -268,12 +268,6 @@ endif()
- # Install Targets (Generic, All Platforms)
-
-
--# important to make a clean install each time, else old scripts get loaded.
--install(
-- CODE
-- "file(REMOVE_RECURSE ${TARGETDIR_VER})"
--)
--
- if(WITH_PYTHON)
- # install(CODE "message(\"copying blender scripts...\")")
-
diff --git a/media-gfx/blender/files/blender-2.70-sse2.patch b/media-gfx/blender/files/blender-2.70-sse2.patch
deleted file mode 100644
index 6fc870ea3258..000000000000
--- a/media-gfx/blender/files/blender-2.70-sse2.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-commit 0e0b27a589680e10e38a26575ad4dba8f3af2ec6
-Author: hasufell <hasufell@gentoo.org>
-Date: Fri Jul 19 18:50:19 2013 +0200
-
- add option to explicitly control sse2 optimization
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 78bb3c6..d5f4576 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -86,6 +86,7 @@
- #-----------------------------------------------------------------------------
- # Load some macros.
- include(build_files/cmake/macros.cmake)
-+include(CMakeDependentOption)
-
-
- #-----------------------------------------------------------------------------
-@@ -251,6 +252,7 @@
- # Misc
- option(WITH_INPUT_NDOF "Enable NDOF input devices (SpaceNavigator and friends)" ON)
- option(WITH_RAYOPTIMIZATION "Enable use of SIMD (SSE) optimizations for the raytracer" ON)
-+cmake_dependent_option(WITH_SSE2 "SSE2 optimizations" ON WITH_RAYOPTIMIZATION OFF)
- option(WITH_OPENNL "Enable use of Open Numerical Library" ON)
- if(UNIX AND NOT APPLE)
- option(WITH_INSTALL_PORTABLE "Install redistributeable runtime, otherwise install into CMAKE_INSTALL_PREFIX" ON)
-@@ -1950,7 +1952,7 @@
- set(PLATFORM_CFLAGS " ${COMPILER_SSE_FLAG} ${PLATFORM_CFLAGS}")
- add_definitions(-D__SSE__ -D__MMX__)
- endif()
-- if(SUPPORT_SSE2_BUILD)
-+ if(WITH_SSE2 AND SUPPORT_SSE2_BUILD)
- set(PLATFORM_CFLAGS " ${COMPILER_SSE2_FLAG} ${PLATFORM_CFLAGS}")
- add_definitions(-D__SSE2__)
- if(NOT SUPPORT_SSE_BUILD) # dont double up
diff --git a/media-gfx/blender/files/blender-2.72-T42797.diff b/media-gfx/blender/files/blender-2.72-T42797.diff
deleted file mode 100644
index cef03853434c..000000000000
--- a/media-gfx/blender/files/blender-2.72-T42797.diff
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/source/blender/blenfont/intern/blf_glyph.c
-+++ a/source/blender/blenfont/intern/blf_glyph.c
-@@ -262,8 +262,8 @@
- g->xoff = -1;
- g->yoff = -1;
- bitmap = slot->bitmap;
-- g->width = bitmap.width;
-- g->height = bitmap.rows;
-+ g->width = (int)bitmap.width;
-+ g->height = (int)bitmap.rows;
-
- if (g->width && g->height) {
- if (sharp) {
diff --git a/media-gfx/blender/files/blender-2.72b-fix-util_simd.patch b/media-gfx/blender/files/blender-2.72b-fix-util_simd.patch
deleted file mode 100644
index 8c83ee096284..000000000000
--- a/media-gfx/blender/files/blender-2.72b-fix-util_simd.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/intern/cycles/util/util_simd.h 2014-10-20 12:58:22.000000000 +0500
-+++ b/intern/cycles/util/util_simd.h 2015-05-17 11:57:37.000000000 +0500
-@@ -19,6 +19,7 @@
- #define __UTIL_SIMD_TYPES_H__
-
- #include <limits>
-+#include <x86intrin.h>
-
- #include "util_debug.h"
- #include "util_types.h"
diff --git a/media-gfx/blender/files/blender-2.72b-gcc6-fixes.patch b/media-gfx/blender/files/blender-2.72b-gcc6-fixes.patch
deleted file mode 100644
index 1c4ab09e62cb..000000000000
--- a/media-gfx/blender/files/blender-2.72b-gcc6-fixes.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-diff -purN a/source/blender/imbuf/intern/dds/ColorBlock.cpp b/source/blender/imbuf/intern/dds/ColorBlock.cpp
---- a/source/blender/imbuf/intern/dds/ColorBlock.cpp 2014-10-20 08:58:23.000000000 +0100
-+++ b/source/blender/imbuf/intern/dds/ColorBlock.cpp 2016-09-22 15:50:25.359318967 +0100
-@@ -86,8 +86,8 @@ void ColorBlock::init(const Image *img,
-
- void ColorBlock::init(uint w, uint h, const uint *data, uint x, uint y)
- {
-- const uint bw = min(w - x, 4U);
-- const uint bh = min(h - y, 4U);
-+ const uint bw = MIN(w - x, 4U);
-+ const uint bh = MIN(h - y, 4U);
-
- // Blocks that are smaller than 4x4 are handled by repeating the pixels.
- // @@ Thats only correct when block size is 1, 2 or 4, but not with 3. :(
-@@ -107,8 +107,8 @@ void ColorBlock::init(uint w, uint h, co
-
- void ColorBlock::init(uint w, uint h, const float *data, uint x, uint y)
- {
-- const uint bw = min(w - x, 4U);
-- const uint bh = min(h - y, 4U);
-+ const uint bw = MIN(w - x, 4U);
-+ const uint bh = MIN(h - y, 4U);
-
- // Blocks that are smaller than 4x4 are handled by repeating the pixels.
- // @@ Thats only correct when block size is 1, 2 or 4, but not with 3. :(
-@@ -124,10 +124,10 @@ void ColorBlock::init(uint w, uint h, co
- const uint idx = ((y + by) * w + x + bx);
-
- Color32 & c = color(e, i);
-- c.r = uint8(255 * clamp(data[idx + 0 * srcPlane], 0.0f, 1.0f)); // @@ Is this the right way to quantize floats to bytes?
-- c.g = uint8(255 * clamp(data[idx + 1 * srcPlane], 0.0f, 1.0f));
-- c.b = uint8(255 * clamp(data[idx + 2 * srcPlane], 0.0f, 1.0f));
-- c.a = uint8(255 * clamp(data[idx + 3 * srcPlane], 0.0f, 1.0f));
-+ c.r = uint8(255 * CLAMP(data[idx + 0 * srcPlane], 0.0f, 1.0f)); // @@ Is this the right way to quantize floats to bytes?
-+ c.g = uint8(255 * CLAMP(data[idx + 1 * srcPlane], 0.0f, 1.0f));
-+ c.b = uint8(255 * CLAMP(data[idx + 2 * srcPlane], 0.0f, 1.0f));
-+ c.a = uint8(255 * CLAMP(data[idx + 3 * srcPlane], 0.0f, 1.0f));
- }
- }
- }
-diff -purN a/source/blender/imbuf/intern/dds/Common.h b/source/blender/imbuf/intern/dds/Common.h
---- a/source/blender/imbuf/intern/dds/Common.h 2014-10-20 08:58:23.000000000 +0100
-+++ b/source/blender/imbuf/intern/dds/Common.h 2016-09-22 15:47:31.327081239 +0100
-@@ -28,14 +28,14 @@
- #ifndef __COMMON_H__
- #define __COMMON_H__
-
--#ifndef min
--#define min(a,b) ((a) <= (b) ? (a) : (b))
-+#ifndef MIN
-+#define MIN(a,b) ((a) <= (b) ? (a) : (b))
- #endif
--#ifndef max
--#define max(a,b) ((a) >= (b) ? (a) : (b))
-+#ifndef MAX
-+#define MAX(a,b) ((a) >= (b) ? (a) : (b))
- #endif
--#ifndef clamp
--#define clamp(x,a,b) min(max((x), (a)), (b))
-+#ifndef CLAMP
-+#define CLAMP(x,a,b) MIN(MAX((x), (a)), (b))
- #endif
-
- template<typename T>
-diff -purN a/source/blender/imbuf/intern/dds/DirectDrawSurface.cpp b/source/blender/imbuf/intern/dds/DirectDrawSurface.cpp
---- a/source/blender/imbuf/intern/dds/DirectDrawSurface.cpp 2014-10-20 08:58:23.000000000 +0100
-+++ b/source/blender/imbuf/intern/dds/DirectDrawSurface.cpp 2016-09-22 16:10:53.985775837 +0100
-@@ -1102,8 +1102,8 @@ void DirectDrawSurface::mipmap(Image *im
- // Compute width and height.
- for (uint m = 0; m < mipmap; m++)
- {
-- w = max(1U, w / 2);
-- h = max(1U, h / 2);
-+ w = MAX(1U, w / 2);
-+ h = MAX(1U, h / 2);
- }
-
- img->allocate(w, h);
-@@ -1223,9 +1223,9 @@ void DirectDrawSurface::readBlockImage(I
- readBlock(&block);
-
- // Write color block.
-- for (uint y = 0; y < min(4U, h-4*by); y++)
-+ for (uint y = 0; y < MIN(4U, h-4*by); y++)
- {
-- for (uint x = 0; x < min(4U, w-4*bx); x++)
-+ for (uint x = 0; x < MIN(4U, w-4*bx); x++)
- {
- img->pixel(4*bx+x, 4*by+y) = block.color(x, y);
- }
-@@ -1240,7 +1240,7 @@ static Color32 buildNormal(uint8 x, uint
- float ny = 2 * (y / 255.0f) - 1;
- float nz = 0.0f;
- if (1 - nx*nx - ny*ny > 0) nz = sqrt(1 - nx*nx - ny*ny);
-- uint8 z = clamp(int(255.0f * (nz + 1) / 2.0f), 0, 255);
-+ uint8 z = CLAMP(int(255.0f * (nz + 1) / 2.0f), 0, 255);
-
- return Color32(x, y, z);
- }
-@@ -1379,9 +1379,9 @@ uint DirectDrawSurface::mipmapSize(uint
-
- for (uint m = 0; m < mipmap; m++)
- {
-- w = max(1U, w / 2);
-- h = max(1U, h / 2);
-- d = max(1U, d / 2);
-+ w = MAX(1U, w / 2);
-+ h = MAX(1U, h / 2);
-+ d = MAX(1U, d / 2);
- }
-
- if (header.pf.flags & DDPF_FOURCC)
-diff -purN a/source/blender/imbuf/intern/dds/FlipDXT.cpp b/source/blender/imbuf/intern/dds/FlipDXT.cpp
---- a/source/blender/imbuf/intern/dds/FlipDXT.cpp 2014-10-20 08:58:23.000000000 +0100
-+++ b/source/blender/imbuf/intern/dds/FlipDXT.cpp 2016-09-22 16:11:35.626829002 +0100
-@@ -246,8 +246,8 @@ int FlipDXTCImage(unsigned int width, un
-
- // mip levels are contiguous.
- data += block_bytes * blocks;
-- mip_width = max(1U, mip_width >> 1);
-- mip_height = max(1U, mip_height >> 1);
-+ mip_width = MAX(1U, mip_width >> 1);
-+ mip_height = MAX(1U, mip_height >> 1);
- }
-
- return 1;