summaryrefslogtreecommitdiff
path: root/media-gfx/blender/blender-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/blender/blender-9999.ebuild')
-rw-r--r--media-gfx/blender/blender-9999.ebuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/media-gfx/blender/blender-9999.ebuild b/media-gfx/blender/blender-9999.ebuild
index 11870198acb9..95fefb89052d 100644
--- a/media-gfx/blender/blender-9999.ebuild
+++ b/media-gfx/blender/blender-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_10 python3_11 )
inherit check-reqs cmake flag-o-matic pax-utils python-single-r1 toolchain-funcs xdg-utils
@@ -14,8 +14,9 @@ if [[ ${PV} = *9999* ]] ; then
# Subversion is needed for downloading unit test files
inherit git-r3 subversion
EGIT_REPO_URI="https://projects.blender.org/blender/blender.git"
+ ADDONS_EGIT_REPO_URI="https://projects.blender.org/blender/blender-addons.git"
else
- SRC_URI="https://projects.blender.org/blender/blender/archive/v${PV}.tar.gz"
+ SRC_URI="https://download.blender.org/source/${P}.tar.xz"
# Update these between major releases.
TEST_TARBALL_VERSION="$(ver_cut 1-2).0"
SRC_URI+=" test? ( https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-${TEST_TARBALL_VERSION}-tests.tar.xz )"
@@ -24,18 +25,18 @@ fi
SLOT="${PV%.*}"
LICENSE="|| ( GPL-3 BL )"
-IUSE="+bullet +dds +fluid +openexr +tbb \
- alembic collada +color-management cuda +cycles \
- debug doc +embree +ffmpeg +fftw +gmp jack jemalloc jpeg2k \
- man +nanovdb ndof nls openal +oidn +openimageio +openmp +opensubdiv \
- +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile \
- test +tiff valgrind wayland X"
+IUSE="+bullet +dds +fluid +openexr +tbb
+ alembic collada +color-management cuda +cycles cycles-bin-kernels
+ debug doc +embree +ffmpeg +fftw +gmp jack jemalloc jpeg2k
+ man +nanovdb ndof nls openal +oidn +openmp +openpgl +opensubdiv
+ +openvdb optix +osl +pdf +potrace +pugixml pulseaudio sdl
+ +sndfile test +tiff valgrind wayland X"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
alembic? ( openexr )
cuda? ( cycles )
- cycles? ( openexr tiff openimageio )
+ cycles? ( openexr tiff )
fluid? ( tbb )
openvdb? ( tbb )
optix? ( cuda )
@@ -58,6 +59,7 @@ RDEPEND="${PYTHON_DEPS}
media-libs/libjpeg-turbo:=
media-libs/libpng:=
media-libs/libsamplerate
+ >=media-libs/openimageio-2.4.6.0:=
sys-libs/zlib:=
virtual/glu
virtual/libintl
@@ -80,11 +82,11 @@ RDEPEND="${PYTHON_DEPS}
nls? ( virtual/libiconv )
openal? ( media-libs/openal )
oidn? ( >=media-libs/oidn-1.4.1 )
- openimageio? ( >=media-libs/openimageio-2.4.6.0:= )
openexr? (
>=dev-libs/imath-3.1.4-r2:=
>=media-libs/openexr-3:0=
)
+ openpgl? ( media-libs/openpgl )
opensubdiv? ( >=media-libs/opensubdiv-3.4.0 )
openvdb? (
>=media-gfx/openvdb-9.0.0:=[nanovdb?]
@@ -168,10 +170,16 @@ pkg_setup() {
src_unpack() {
if [[ ${PV} = *9999* ]] ; then
git-r3_src_unpack
+
+ git-r3_fetch ${ADDONS_EGIT_REPO_URI}
+ git-r3_checkout ${ADDONS_EGIT_REPO_URI} ${S}/scripts/addons
+
if use test; then
TESTS_SVN_URL=https://svn.blender.org/svnroot/bf-blender/trunk/lib/tests
subversion_fetch ${TESTS_SVN_URL} ../lib/tests
fi
+ ASSETS_SVN_URL=https://svn.blender.org/svnroot/bf-blender/trunk/lib/assets
+ subversion_fetch ${ASSETS_SVN_URL} ../lib/assets
else
default
if use test; then
@@ -230,10 +238,12 @@ src_configure() {
-DWITH_CODEC_SNDFILE=$(usex sndfile)
-DWITH_CXX_GUARDEDALLOC=$(usex debug)
-DWITH_CYCLES=$(usex cycles)
+ -DWITH_CYCLES_CUDA_BINARIES=$(usex cycles-bin-kernels)
-DWITH_CYCLES_DEVICE_CUDA=$(usex cuda TRUE FALSE)
-DWITH_CYCLES_DEVICE_OPTIX=$(usex optix)
-DWITH_CYCLES_EMBREE=$(usex embree)
-DWITH_CYCLES_OSL=$(usex osl)
+ -DWITH_CYCLES_PATH_GUIDING=$(usex openpgl)
-DWITH_CYCLES_STANDALONE=OFF
-DWITH_CYCLES_STANDALONE_GUI=OFF
-DWITH_DOC_MANPAGE=$(usex man)
@@ -265,7 +275,6 @@ src_configure() {
-DWITH_OPENCOLLADA=$(usex collada)
-DWITH_OPENCOLORIO=$(usex color-management)
-DWITH_OPENIMAGEDENOISE=$(usex oidn)
- -DWITH_OPENIMAGEIO=$(usex openimageio)
-DWITH_OPENMP=$(usex openmp)
-DWITH_OPENSUBDIV=$(usex opensubdiv)
-DWITH_OPENVDB=$(usex openvdb)