summaryrefslogtreecommitdiff
path: root/media-gfx/album/album-4.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/album/album-4.15.ebuild')
-rw-r--r--media-gfx/album/album-4.15.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/album/album-4.15.ebuild b/media-gfx/album/album-4.15.ebuild
new file mode 100644
index 000000000000..29747bb6555f
--- /dev/null
+++ b/media-gfx/album/album-4.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="HTML photo album generator"
+HOMEPAGE="https://marginalhacks.com/Hacks/album/"
+SRC_URI="https://marginalhacks.com/bin/album.versions/${P}.tar.gz
+ https://marginalhacks.com/bin/album.versions/data-4.05.tar.gz"
+
+LICENSE="marginalhacks"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc ffmpeg plugins themes"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ media-gfx/jhead
+ virtual/imagemagick-tools
+ ffmpeg? ( virtual/ffmpeg )"
+
+src_install() {
+ dobin album
+ doman album.1
+ dodoc License.txt CHANGELOG
+ use doc && dohtml -r Docs/*
+
+ dodir /usr/share/album
+ insinto /usr/share/album
+ cd ..
+ doins -r lang
+ use themes && doins -r Themes
+ use plugins && doins -r plugins
+}
+
+pkg_postinst() {
+ elog "For some optional tools please browse:"
+ elog "https://MarginalHacks.com/Hacks/album/tools/"
+}