summaryrefslogtreecommitdiff
path: root/mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild')
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild b/mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild
new file mode 100644
index 000000000000..560e13d531c9
--- /dev/null
+++ b/mail-filter/zdkimfilter/zdkimfilter-1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+DESCRIPTION="DKIM filter for Courier-MTA"
+HOMEPAGE="http://www.tana.it/sw/zdkimfilter"
+SRC_URI="http://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opendbx"
+
+DEPEND=">=mail-filter/opendkim-2.2.0
+ mail-mta/courier
+ opendbx? ( >=dev-db/opendbx-1.4.0 )
+ dev-libs/nettle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use opendbx; then
+ # remove opendbx stuff
+ sed -i -e '12342,12450d' configure || die
+ fi
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm "${D}"/etc/courier/filters/zdkimfilter.conf || die
+ diropts -o mail -g mail
+ dodir /etc/courier/filters/keys
+ dodoc release-notes-*.txt
+ dodoc odbx_example.{conf,sql}
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} == 0.5 ]]; then
+ ewarn "Database access is now through opendbx. Please see the"
+ ewarn "zfilter_db man page and example config files in"
+ ewarn "\t/usr/share/doc/${P}"
+ ewarn "Some config file options have changed. Please see the"
+ ewarn "release-notes."
+ fi
+}