summaryrefslogtreecommitdiff
path: root/mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild')
-rw-r--r--mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild b/mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild
deleted file mode 100644
index 14de72aa96c2..000000000000
--- a/mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 python3_8 )
-
-# The built-in ipaddress module handles the parsing of IP addresses. If
-# python is built without ipv6 support, then ipaddress can't parse ipv6
-# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
-# other words, it's completely broken.
-PYTHON_REQ_USE="ipv6"
-
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1
-
-OLD_PN="pypolicyd-spf"
-OLD_P="${OLD_PN}-${PV}"
-OLD_PF="${PN}-${PVR}"
-DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
-HOMEPAGE="https://launchpad.net/pypolicyd-spf"
-SRC_URI="mirror://pypi/p/${OLD_PN}/${OLD_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
-
-RDEPEND="${DEPEND}
- dev-python/authres[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${OLD_P}"
-
-DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
-
-python_prepare_all() {
- # The "real" config file mentions the commented one, so we point
- # users in the right direction.
- local oldconf="policyd-spf.conf.commented"
- local newconf="/usr/share/doc/${OLD_PF}/${oldconf}"
-
- sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
- || die 'failed to update commented config file path'
-
- distutils-r1_python_prepare_all
-}