summaryrefslogtreecommitdiff
path: root/mail-filter/postforward
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/postforward')
-rw-r--r--mail-filter/postforward/Manifest4
-rw-r--r--mail-filter/postforward/files/postforward_apply-sendmail-path.patch11
-rw-r--r--mail-filter/postforward/metadata.xml17
-rw-r--r--mail-filter/postforward/postforward-1.1.0.ebuild47
4 files changed, 79 insertions, 0 deletions
diff --git a/mail-filter/postforward/Manifest b/mail-filter/postforward/Manifest
new file mode 100644
index 000000000000..8133e592f4af
--- /dev/null
+++ b/mail-filter/postforward/Manifest
@@ -0,0 +1,4 @@
+AUX postforward_apply-sendmail-path.patch 722 BLAKE2B b8585995206ebe6a608200b85a3eba3df3deae1682f22e4171be9c2f055593e827cfc4753b276d544da5a59f71f374575fcbf8544e4d12738280fcdb770bf8d4 SHA512 17685c2bde9ca3057f4da06553b19e2dde556788c009e9ea005b7b87af687643f9233decf4fa30f4fbd885317f4b3fa283af3d2b1b98c5621df90616ae8751aa
+DIST postforward-1.1.0.tar.gz 5707 BLAKE2B 2dc994628820b40caf3b9c65ad6be48e220abff8f5a6d6054b109600d9d368fab3e6e642dbc5a98235f440359600a3f4bbc19f7ead06fd84802a8900fa465dc1 SHA512 39d7a33c454b1529a691b24fd69b311ba368caf59168d39146654cfe319ebc3cf73835e66e6c95a43747f389a6b954ac8da0d7e934e562c16cb85dc20c0f4804
+EBUILD postforward-1.1.0.ebuild 1233 BLAKE2B 1c2b462dad4f4e60977805989c53ae9add3adec82cd3c5f4e2526579f482eba8bf636b69f9ac8e9abb2c4e730526dfef0ea7b854a0e9723b249f13d90e707192 SHA512 021a0d20e6f2e22cb9073e8563ad3a2b6e6daa345b4eb95b9bb45a860f82d1ff8db5f1e12bcdc3e88faadfb4be354e9fce0abd8121fce38888fb86cb0b445e3b
+MISC metadata.xml 486 BLAKE2B 478f6cd3c58e0235b4ddc697254bdcadedf4d2b2895bdd840b69062072ee23a2185935eade9bf596fd8640ec5af2fae7360353c9120b6bfb42d03b727ed41c0a SHA512 50563f5896bcf6f4ce8f2bdf3da492c8ff0ddd5162366a64c0c0ebb3f9125431e139ebcfa0a2b4a7aabae929d366862c2f687b638469e135d3a8a1b0e1d21c3e
diff --git a/mail-filter/postforward/files/postforward_apply-sendmail-path.patch b/mail-filter/postforward/files/postforward_apply-sendmail-path.patch
new file mode 100644
index 000000000000..c64b76368a39
--- /dev/null
+++ b/mail-filter/postforward/files/postforward_apply-sendmail-path.patch
@@ -0,0 +1,11 @@
+--- a/postforward.go
++++ b/postforward.go
+@@ -27,7 +27,7 @@ const (
+ )
+
+ var dryRun = flag.Bool("dry-run", false, "show what would be done, don't actually forward mail")
+-var path = flag.String("path", "", "override $PATH with this value when executing binaries")
++var path = flag.String("path", "@GENTOO_PORTAGE_EPREFIX@/usr/sbin", "override $PATH with this value when executing binaries")
+ var rpHeader = flag.String("rp-header", "Return-Path", "header name containing the return-path (MAIL FROM) value")
+ var sendmailPath = flag.String("sendmail-path", "sendmail", "path to the sendmail binary (deprecated: use --path instead)")
+ var srsAddr = flag.String("srs-addr", "localhost:10001", "TCP address for SRS lookups")
diff --git a/mail-filter/postforward/metadata.xml b/mail-filter/postforward/metadata.xml
new file mode 100644
index 000000000000..e9e4ddc46066
--- /dev/null
+++ b/mail-filter/postforward/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo_bugs_peep@parallaxshift.com</email>
+ <name>Philippe Chaintreuil</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="github">zoni/postforward</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-filter/postforward/postforward-1.1.0.ebuild b/mail-filter/postforward/postforward-1.1.0.ebuild
new file mode 100644
index 000000000000..681a874c9e66
--- /dev/null
+++ b/mail-filter/postforward/postforward-1.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils golang-build
+
+DESCRIPTION="Postfix Sender Rewriting Scheme forwarding agent"
+EGO_PN="${PN}"
+SRC_URI="https://github.com/zoni/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/zoni/postforward"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-lang/go:0"
+RDEPEND="
+ mail-filter/postsrsd"
+
+PATCHES=( "${FILESDIR}/${PN}_apply-sendmail-path.patch" )
+
+src_prepare() {
+ default
+
+ # Dynamically fix EPREFIX lines made by ${PN}_apply-sendmail-path.patch
+ sed -i -e "s/@GENTOO_PORTAGE_EPREFIX@/${EPREFIX}/" *.go || die
+
+ # go build assumes files will be in src dir, but
+ # source files are in root in this package, so move
+ # them.
+ local new_src_dir="${S}/src/${EGO_PN}"
+ # Freak out if there's already something there because
+ # it means the package has changed and we'll need to
+ # adjust to it.
+ [[ ! -e "${new_src_dir}" ]] || die "${new_src_dir} already exists"
+ mkdir -p "${new_src_dir}" || die
+ mv *.go "${new_src_dir}" || die
+}
+
+# Standard golang-build src_install complains about pkg not
+# existing, so we go custom.
+src_install() {
+ einstalldocs
+ dosbin "${PN}"
+}