summaryrefslogtreecommitdiff
path: root/mail-filter/exim-p0f/exim-p0f-0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/exim-p0f/exim-p0f-0.1-r1.ebuild')
-rw-r--r--mail-filter/exim-p0f/exim-p0f-0.1-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail-filter/exim-p0f/exim-p0f-0.1-r1.ebuild b/mail-filter/exim-p0f/exim-p0f-0.1-r1.ebuild
index 8c3b300d1dee..7c203487939e 100644
--- a/mail-filter/exim-p0f/exim-p0f-0.1-r1.ebuild
+++ b/mail-filter/exim-p0f/exim-p0f-0.1-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils flag-o-matic ltprune
+EAPI=7
+
+inherit flag-o-matic
DESCRIPTION="This is p0f version 3 dlfunc library for Exim"
HOMEPAGE="https://dist.epipe.com/exim/"
@@ -16,6 +17,7 @@ IUSE=""
DEPEND="mail-mta/exim[dlfunc]"
RDEPEND=">=net-analyzer/p0f-3.05_beta
${DEPEND}"
+
S="${WORKDIR}/exim-p0f3-dlfunc-${PV}"
src_configure() {
@@ -25,5 +27,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die "Failed to prune libtool files"
}