summaryrefslogtreecommitdiff
path: root/mail-client/thunderbird/thunderbird-115.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/thunderbird/thunderbird-115.10.1.ebuild')
-rw-r--r--mail-client/thunderbird/thunderbird-115.10.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/mail-client/thunderbird/thunderbird-115.10.1.ebuild b/mail-client/thunderbird/thunderbird-115.10.1.ebuild
index 1b82272c326d..b05e9d125a55 100644
--- a/mail-client/thunderbird/thunderbird-115.10.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-115.10.1.ebuild
@@ -1015,7 +1015,13 @@ src_configure() {
# With Firefox-115esr elf-hack=relr isn't available (only in rapid).
# Solution: Disable build system's elf-hack completely, and add "-z,pack-relative-relocs"
# manually with gcc.
- mozconfig_add_options_ac 'elf-hack disabled' --disable-elf-hack
+ #
+ # # elf-hack configure option isn't available on ppc64/riscv, #916259, #929244, #930046.
+ if use ppc64 || use riscv ; then
+ :;
+ else
+ mozconfig_add_options_ac 'elf-hack disabled' --disable-elf-hack
+ fi
if use amd64 || use x86 ; then
! use clang && append-ldflags "-z,pack-relative-relocs"