summaryrefslogtreecommitdiff
path: root/mail-client/mailx-support/mailx-support-20060102-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mailx-support/mailx-support-20060102-r3.ebuild')
-rw-r--r--mail-client/mailx-support/mailx-support-20060102-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/mail-client/mailx-support/mailx-support-20060102-r3.ebuild b/mail-client/mailx-support/mailx-support-20060102-r3.ebuild
new file mode 100644
index 000000000000..aaf5b7c38363
--- /dev/null
+++ b/mail-client/mailx-support/mailx-support-20060102-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Provides lockspool utility"
+HOMEPAGE="http://www.openbsd.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-ldflags.patch
+ "${FILESDIR}"/${P}-add-sys_file_h.patch
+)
+
+RDEPEND="!mail-mta/opensmtpd"
+
+src_prepare() {
+ default
+
+ # This code should only be ran with Gentoo Prefix profiles
+ if use prefix; then
+ ebegin "Allowing unprivileged install"
+ sed -i -e "s|-g 0 -o 0||g" Makefile
+ eend $?
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" BINDNOW_FLAGS=""
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}