summaryrefslogtreecommitdiff
path: root/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mailx-support/mailx-support-20060102-r2.ebuild')
-rw-r--r--mail-client/mailx-support/mailx-support-20060102-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail-client/mailx-support/mailx-support-20060102-r2.ebuild b/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
new file mode 100644
index 000000000000..af46a2765d7c
--- /dev/null
+++ b/mail-client/mailx-support/mailx-support-20060102-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Provides lockspool utility"
+HOMEPAGE="http://www.openbsd.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+ epatch "${FILESDIR}"/${P}-add-sys_file_h.patch
+
+ # This code should only be ran with Gentoo Prefix profiles
+ if use prefix; then
+ ebegin "Allowing unprivileged install"
+ sed -i -e "s|-g 0 -o 0||g" Makefile
+ eend $?
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" BINDNOW_FLAGS="" || die "emake failed"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}