summaryrefslogtreecommitdiff
path: root/mail-client/kube/files
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/kube/files')
-rw-r--r--mail-client/kube/files/kube-0.7.0-appdata-location.patch23
-rw-r--r--mail-client/kube/files/kube-0.7.0-require-cxx14.patch37
-rw-r--r--mail-client/kube/files/kube-0.7.0-tests-optional.patch62
3 files changed, 0 insertions, 122 deletions
diff --git a/mail-client/kube/files/kube-0.7.0-appdata-location.patch b/mail-client/kube/files/kube-0.7.0-appdata-location.patch
deleted file mode 100644
index 6e771c037177..000000000000
--- a/mail-client/kube/files/kube-0.7.0-appdata-location.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From bf9e6bc6e9885d30f2db124e803403ea327af138 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sat, 10 Oct 2020 17:55:19 +0200
-Subject: [PATCH] Fix appdata installation path to /usr/share/metainfo
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- applications/kube/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/applications/kube/CMakeLists.txt b/applications/kube/CMakeLists.txt
-index 761d1f18..f92f66f0 100644
---- a/applications/kube/CMakeLists.txt
-+++ b/applications/kube/CMakeLists.txt
-@@ -49,4 +49,4 @@ set(KUBE_APPDATA_HELP "https://kube.readthedocs.io/en/latest/" CACHE STRING "app
- set(KUBE_APPDATA_PROJECTGROUP "KDE" CACHE STRING "appdata projectgroup property")
- set(KUBE_APPDATAFILENAME "${KUBE_APPLICATION_ID}.appdata.xml")
- configure_file(kube.appdata.xml.in ${KUBE_APPDATAFILENAME})
--install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${KUBE_APPDATAFILENAME} DESTINATION ${KDE_INSTALL_DATAROOTDIR}/appdata/)
-+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${KUBE_APPDATAFILENAME} DESTINATION ${KDE_INSTALL_DATAROOTDIR}/metainfo/)
---
-2.28.0
-
diff --git a/mail-client/kube/files/kube-0.7.0-require-cxx14.patch b/mail-client/kube/files/kube-0.7.0-require-cxx14.patch
deleted file mode 100644
index 86578099e269..000000000000
--- a/mail-client/kube/files/kube-0.7.0-require-cxx14.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Upstream commits combined (and backported) to save space:
-c38edcfe12b68585641eb925321067e3db811766
-6b15ef07013259176aac938ac529715aaf88fdfe
-fceffd0d10ff203334a933e99a3ea52593ea14d5
-
-Subject: [PATCH] Properly require c++ 14
-
---- b/extensions/api/src/CMakeLists.txt
-+++ b/extensions/api/src/CMakeLists.txt
-@@ -1,5 +1,4 @@
- set(CMAKE_CXX_VISIBILITY_PRESET default)
--set(CMAKE_CXX_STANDARD_REQUIRED 14)
-
- find_package(Qt5 COMPONENTS REQUIRED Core Concurrent Quick Qml WebEngineWidgets Test WebEngine Gui)
- find_package(KF5Mime 4.87.0 CONFIG REQUIRED)
---- b/framework/src/CMakeLists.txt
-+++ b/framework/src/CMakeLists.txt
-@@ -11,7 +11,6 @@
- include(GenerateExportHeader)
-
- set(CMAKE_CXX_VISIBILITY_PRESET default)
--set(CMAKE_CXX_STANDARD_REQUIRED 14)
-
- include_directories(. domain/mime/mimetreeparser domain/ domain/mime)
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -50,6 +50,9 @@ configure_file(kube_version.h.in ${CMAKE_BINARY_DIR}/kube_version.h)
-
- enable_testing()
-
-+set(CMAKE_CXX_STANDARD 14)
-+set(CMAKE_CXX_STANDARD_REQUIRED ON)
-+
- include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
- add_subdirectory(framework)
- add_subdirectory(components)
diff --git a/mail-client/kube/files/kube-0.7.0-tests-optional.patch b/mail-client/kube/files/kube-0.7.0-tests-optional.patch
deleted file mode 100644
index 0756cfb0cadd..000000000000
--- a/mail-client/kube/files/kube-0.7.0-tests-optional.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- a/CMakeLists.txt 2019-09-29 21:36:28.419106801 +0200
-+++ b/CMakeLists.txt 2019-09-29 21:36:28.423106839 +0200
-@@ -43,7 +43,9 @@
- add_subdirectory(applications)
- add_subdirectory(views)
- add_subdirectory(accounts)
-+if(BUILD_TESTING)
- add_subdirectory(tests)
-+endif()
- if (${ENABLE_EXTENSION})
- add_subdirectory(extensions)
- endif()
---- a/framework/CMakeLists.txt 2019-09-29 21:36:28.428106886 +0200
-+++ b/framework/CMakeLists.txt 2019-09-29 21:36:28.433106934 +0200
-@@ -4,4 +4,6 @@
- install(FILES qmldir DESTINATION ${FRAMEWORK_INSTALL_DIR})
-
- add_subdirectory(src)
-+if(BUILD_TESTING)
- add_subdirectory(qml/tests)
-+endif()
---- a/framework/src/CMakeLists.txt 2019-09-29 21:36:28.437106972 +0200
-+++ b/framework/src/CMakeLists.txt 2019-09-29 21:36:28.450107095 +0200
-@@ -86,10 +86,16 @@
-
- set(BUILD_TESTING ON)
-
-+if(BUILD_TESTING)
- add_subdirectory(tests)
-+endif()
- add_subdirectory(domain/mime)
-+if(BUILD_TESTING)
- add_subdirectory(domain/mime/tests)
-+endif()
- add_subdirectory(domain/mime/mimetreeparser)
-+if(BUILD_TESTING)
- add_subdirectory(domain/settings/tests)
-+endif()
-
- feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
---- a/framework/src/domain/mime/mimetreeparser/CMakeLists.txt 2019-09-29 21:36:28.455107143 +0200
-+++ b/framework/src/domain/mime/mimetreeparser/CMakeLists.txt 2019-09-29 21:36:28.458107171 +0200
-@@ -49,5 +49,7 @@
- Gpgme::Gpgme
- )
-
-+if(BUILD_TESTING)
- add_subdirectory(autotests)
- add_subdirectory(tests)
-+endif()
---- a/components/CMakeLists.txt 2019-09-29 21:36:28.463107218 +0200
-+++ b/components/CMakeLists.txt 2019-09-29 21:36:28.476107341 +0200
-@@ -8,7 +8,9 @@
- endmacro(install_qml_component)
-
- install_qml_component(kube)
-+if(BUILD_TESTING)
- add_subdirectory(kube/tests)
-+endif()
- install_qml_component(accounts)
-
-