summaryrefslogtreecommitdiff
path: root/mail-client/aerc/aerc-0.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/aerc/aerc-0.3.0-r1.ebuild')
-rw-r--r--mail-client/aerc/aerc-0.3.0-r1.ebuild136
1 files changed, 112 insertions, 24 deletions
diff --git a/mail-client/aerc/aerc-0.3.0-r1.ebuild b/mail-client/aerc/aerc-0.3.0-r1.ebuild
index 58fbbeb85dda..8ed4ce117d80 100644
--- a/mail-client/aerc/aerc-0.3.0-r1.ebuild
+++ b/mail-client/aerc/aerc-0.3.0-r1.ebuild
@@ -8,48 +8,136 @@ inherit go-module
DESCRIPTION="Email client for your terminal"
HOMEPAGE="https://aerc-mail.org"
-# go list -m all | magic
-EGO_VENDOR=(
- "git.sr.ht/~sircmpwn/getopt 292febf82fd0 git.sr.ht/~sircmpwn/getopt"
- "git.sr.ht/~sircmpwn/pty 3a43678975a9 git.sr.ht/~sircmpwn/pty"
- "github.com/danwakefield/fnmatch cbb64ac3d964"
+EGO_SUM=(
+ "cloud.google.com/go v0.34.0/go.mod"
+ "git.sr.ht/~sircmpwn/getopt v0.0.0-20190621174457-292febf82fd0"
+ "git.sr.ht/~sircmpwn/getopt v0.0.0-20190621174457-292febf82fd0/go.mod"
+ "git.sr.ht/~sircmpwn/pty v0.0.0-20190330154901-3a43678975a9"
+ "git.sr.ht/~sircmpwn/pty v0.0.0-20190330154901-3a43678975a9/go.mod"
+ "git.sr.ht/~sircmpwn/tcell v0.0.0-20190807054800-3fdb6bc01a50"
+ "git.sr.ht/~sircmpwn/tcell v0.0.0-20190807054800-3fdb6bc01a50/go.mod"
+ "github.com/DATA-DOG/go-sqlmock v1.3.3"
+ "github.com/DATA-DOG/go-sqlmock v1.3.3/go.mod"
+ "github.com/danwakefield/fnmatch v0.0.0-20160403171240-cbb64ac3d964"
+ "github.com/danwakefield/fnmatch v0.0.0-20160403171240-cbb64ac3d964/go.mod"
+ "github.com/davecgh/go-spew v1.1.0"
+ "github.com/davecgh/go-spew v1.1.0/go.mod"
"github.com/davecgh/go-spew v1.1.1"
- "github.com/ddevault/go-libvterm b7d861da3810"
+ "github.com/davecgh/go-spew v1.1.1/go.mod"
+ "github.com/ddevault/go-libvterm v0.0.0-20190526194226-b7d861da3810"
+ "github.com/ddevault/go-libvterm v0.0.0-20190526194226-b7d861da3810/go.mod"
"github.com/emersion/go-imap v1.0.0"
- "github.com/emersion/go-imap-idle 2704abd7050e"
- "github.com/emersion/go-maildir 941194b0ac70"
+ "github.com/emersion/go-imap v1.0.0/go.mod"
+ "github.com/emersion/go-imap-idle v0.0.0-20190519112320-2704abd7050e"
+ "github.com/emersion/go-imap-idle v0.0.0-20190519112320-2704abd7050e/go.mod"
+ "github.com/emersion/go-maildir v0.0.0-20190727102040-941194b0ac70"
+ "github.com/emersion/go-maildir v0.0.0-20190727102040-941194b0ac70/go.mod"
+ "github.com/emersion/go-message v0.10.4-0.20190609165112-592ace5bc1ca/go.mod"
"github.com/emersion/go-message v0.10.7"
- "github.com/emersion/go-sasl 240c8404624e"
+ "github.com/emersion/go-message v0.10.7/go.mod"
+ "github.com/emersion/go-sasl v0.0.0-20190520160400-47d427600317"
+ "github.com/emersion/go-sasl v0.0.0-20190520160400-47d427600317/go.mod"
+ "github.com/emersion/go-sasl v0.0.0-20190704090222-36b50694675c"
+ "github.com/emersion/go-sasl v0.0.0-20190704090222-36b50694675c/go.mod"
+ "github.com/emersion/go-sasl v0.0.0-20190817083125-240c8404624e"
+ "github.com/emersion/go-sasl v0.0.0-20190817083125-240c8404624e/go.mod"
"github.com/emersion/go-smtp v0.11.2"
- "github.com/emersion/go-textwrapper d0e65e56babe"
+ "github.com/emersion/go-smtp v0.11.2/go.mod"
+ "github.com/emersion/go-textwrapper v0.0.0-20160606182133-d0e65e56babe"
+ "github.com/emersion/go-textwrapper v0.0.0-20160606182133-d0e65e56babe/go.mod"
"github.com/fsnotify/fsnotify v1.4.7"
+ "github.com/fsnotify/fsnotify v1.4.7/go.mod"
"github.com/gdamore/encoding v1.0.0"
- "github.com/gdamore/tcell 3fdb6bc01a50 git.sr.ht/~sircmpwn/tcell" # fork
+ "github.com/gdamore/encoding v1.0.0/go.mod"
"github.com/go-ini/ini v1.44.0"
+ "github.com/go-ini/ini v1.44.0/go.mod"
+ "github.com/golang/protobuf v1.2.0/go.mod"
+ "github.com/golang/protobuf v1.3.1/go.mod"
"github.com/golang/protobuf v1.3.2"
- "github.com/google/shlex c34317bd91bf"
+ "github.com/golang/protobuf v1.3.2/go.mod"
+ "github.com/google/shlex v0.0.0-20181106134648-c34317bd91bf"
+ "github.com/google/shlex v0.0.0-20181106134648-c34317bd91bf/go.mod"
+ "github.com/gopherjs/gopherjs v0.0.0-20181017120253-0766667cb4d1"
+ "github.com/gopherjs/gopherjs v0.0.0-20181017120253-0766667cb4d1/go.mod"
+ "github.com/gopherjs/gopherjs v0.0.0-20190430165422-3e4dfb77656c"
+ "github.com/gopherjs/gopherjs v0.0.0-20190430165422-3e4dfb77656c/go.mod"
+ "github.com/jtolds/gls v4.20.0+incompatible"
+ "github.com/jtolds/gls v4.20.0+incompatible/go.mod"
"github.com/kyoh86/xdg v1.0.0"
+ "github.com/kyoh86/xdg v1.0.0/go.mod"
"github.com/lucasb-eyer/go-colorful v1.0.2"
+ "github.com/lucasb-eyer/go-colorful v1.0.2/go.mod"
+ "github.com/martinlindhe/base36 v0.0.0-20190418230009-7c6542dfbb41"
+ "github.com/martinlindhe/base36 v0.0.0-20190418230009-7c6542dfbb41/go.mod"
"github.com/martinlindhe/base36 v1.0.0"
+ "github.com/martinlindhe/base36 v1.0.0/go.mod"
"github.com/mattn/go-isatty v0.0.8"
- "github.com/mattn/go-pointer 49522c3f3791"
+ "github.com/mattn/go-isatty v0.0.8/go.mod"
+ "github.com/mattn/go-pointer v0.0.0-20180825124634-49522c3f3791"
+ "github.com/mattn/go-pointer v0.0.0-20180825124634-49522c3f3791/go.mod"
"github.com/mattn/go-runewidth v0.0.4"
- "github.com/miolini/datacounter aa48df3a02c1"
+ "github.com/mattn/go-runewidth v0.0.4/go.mod"
+ "github.com/miolini/datacounter v0.0.0-20190724021726-aa48df3a02c1"
+ "github.com/miolini/datacounter v0.0.0-20190724021726-aa48df3a02c1/go.mod"
"github.com/mitchellh/go-homedir v1.1.0"
+ "github.com/mitchellh/go-homedir v1.1.0/go.mod"
"github.com/pkg/errors v0.8.1"
+ "github.com/pkg/errors v0.8.1/go.mod"
"github.com/pmezard/go-difflib v1.0.0"
- "github.com/riywo/loginshell 2ed199a032f6"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/riywo/loginshell v0.0.0-20190610082906-2ed199a032f6"
+ "github.com/riywo/loginshell v0.0.0-20190610082906-2ed199a032f6/go.mod"
+ "github.com/smartystreets/assertions v0.0.0-20180927180507-b2de0cb4f26d"
+ "github.com/smartystreets/assertions v0.0.0-20180927180507-b2de0cb4f26d/go.mod"
+ "github.com/smartystreets/assertions v1.0.1"
+ "github.com/smartystreets/assertions v1.0.1/go.mod"
+ "github.com/smartystreets/goconvey v0.0.0-20190710185942-9d28bd7c0945"
+ "github.com/smartystreets/goconvey v0.0.0-20190710185942-9d28bd7c0945/go.mod"
+ "github.com/stretchr/objx v0.1.0/go.mod"
"github.com/stretchr/testify v1.3.0"
- "github.com/zenhack/go.notmuch 5a1961965cfb"
- "golang.org/x/net 74dc4d7220e7 github.com/golang/net"
- "golang.org/x/oauth2 0f29369cfe45 github.com/golang/oauth2"
- "golang.org/x/sys fde4db37ae7a github.com/golang/sys"
- "golang.org/x/text v0.3.2 github.com/golang/text"
- "google.golang.org/appengine v1.6.1 github.com/golang/appengine"
-)
-
+ "github.com/stretchr/testify v1.3.0/go.mod"
+ "github.com/zenhack/go.notmuch v0.0.0-20190726231123-3d59f87d986e"
+ "github.com/zenhack/go.notmuch v0.0.0-20190726231123-3d59f87d986e/go.mod"
+ "github.com/zenhack/go.notmuch v0.0.0-20190821052706-5a1961965cfb"
+ "github.com/zenhack/go.notmuch v0.0.0-20190821052706-5a1961965cfb/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20190605123033-f99c8df09eb5/go.mod"
+ "golang.org/x/image v0.0.0-20190523035834-f03afa92d3ff/go.mod"
+ "golang.org/x/net v0.0.0-20180724234803-3673e40ba225/go.mod"
+ "golang.org/x/net v0.0.0-20190108225652-1e06a53dbb7e/go.mod"
+ "golang.org/x/net v0.0.0-20190311183353-d8887717615a"
+ "golang.org/x/net v0.0.0-20190311183353-d8887717615a/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/net v0.0.0-20190603091049-60506f45cf65/go.mod"
+ "golang.org/x/net v0.0.0-20190813141303-74dc4d7220e7"
+ "golang.org/x/net v0.0.0-20190813141303-74dc4d7220e7/go.mod"
+ "golang.org/x/oauth2 v0.0.0-20190604053449-0f29369cfe45"
+ "golang.org/x/oauth2 v0.0.0-20190604053449-0f29369cfe45/go.mod"
+ "golang.org/x/sync v0.0.0-20181221193216-37e7f081c4d4/go.mod"
+ "golang.org/x/sync v0.0.0-20190423024810-112230192c58/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190222072716-a9d3bda3a223/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20190606165138-5da285871e9c/go.mod"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756/go.mod"
+ "golang.org/x/sys v0.0.0-20190813064441-fde4db37ae7a"
+ "golang.org/x/sys v0.0.0-20190813064441-fde4db37ae7a/go.mod"
+ "golang.org/x/text v0.3.0"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.2"
+ "golang.org/x/text v0.3.2/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+ "golang.org/x/tools v0.0.0-20190328211700-ab21143f2384/go.mod"
+ "golang.org/x/tools v0.0.0-20190606124116-d0a3d012864b/go.mod"
+ "google.golang.org/appengine v1.4.0/go.mod"
+ "google.golang.org/appengine v1.6.1"
+ "google.golang.org/appengine v1.6.1/go.mod"
+ "gopkg.in/ini.v1 v1.44.0"
+ "gopkg.in/ini.v1 v1.44.0/go.mod"
+ )
+go-module_set_globals
SRC_URI="https://git.sr.ht/~sircmpwn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- $(go-module_vendor_uris)"
+ ${EGO_SUM_SRC_URI}"
LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"