summaryrefslogtreecommitdiff
path: root/lxde-base/lxlauncher/lxlauncher-0.2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxlauncher/lxlauncher-0.2.5.ebuild')
-rw-r--r--lxde-base/lxlauncher/lxlauncher-0.2.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/lxde-base/lxlauncher/lxlauncher-0.2.5.ebuild b/lxde-base/lxlauncher/lxlauncher-0.2.5.ebuild
new file mode 100644
index 000000000000..1c647a73c1d7
--- /dev/null
+++ b/lxde-base/lxlauncher/lxlauncher-0.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="An open source clone of the Asus launcher for EeePC"
+HOMEPAGE="https://wiki.lxde.org/en/LXLauncher"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2
+ gnome-base/gnome-menus
+ x11-libs/startup-notification"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ lxde-base/menu-cache
+ !lxde-base/lxlauncher-gmenu"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+}