summaryrefslogtreecommitdiff
path: root/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-6.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-6.0.2.ebuild')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-6.0.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-6.0.2.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-6.0.2.ebuild
new file mode 100644
index 000000000000..84e3dc586ce4
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-6.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtbase:=[cups]: includes specifically the cups private header
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtbase-${QTMIN}:6=[cups,dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ || (
+ >=dev-qt/qtbase-${QTMIN}:6[libinput]
+ >=dev-qt/qtbase-${QTMIN}:6[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6[dbus]
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kglobalaccel-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-plasma/kwayland-${PVCUT}:6
+ >=kde-plasma/plasma-workspace-${PVCUT}:6
+ x11-libs/libxkbcommon
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.11.1
+ >=dev-libs/wayland-protocols-1.25
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent]
+"
+RDEPEND="${COMMON_DEPEND}
+ kde-misc/kio-fuse:6
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ virtual/pkgconfig
+"