summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-thunderbolt
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-thunderbolt')
-rw-r--r--kde-plasma/plasma-thunderbolt/Manifest2
-rw-r--r--kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch71
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild40
3 files changed, 113 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/Manifest b/kde-plasma/plasma-thunderbolt/Manifest
index f7dc6a1ae227..289c0810a6b3 100644
--- a/kde-plasma/plasma-thunderbolt/Manifest
+++ b/kde-plasma/plasma-thunderbolt/Manifest
@@ -1,5 +1,7 @@
+AUX plasma-thunderbolt-5.25.5-kcm-crash.patch 2737 BLAKE2B bc5d652b2529f070baef999def0456dc48a253c42975f239d9c8943add1eb06a6536bbc8ab19ef3f9ecfab22641bf4ef36043ed267ebed19cab97c666c992401 SHA512 7b5f538f7904d7d6a452ce9b77da2ac35131dbc6b50294699a2e785c80bab16aa4d99e2f0e1e42acd2444d1067fcb239dc6bf76b169fd3a508aa11a00a3e1bb9
DIST plasma-thunderbolt-5.24.6.tar.xz 66748 BLAKE2B 2f83473a8d03735669c38b6b872da84ac5814811da2213988edbe0acbf1315bcecda54f470ac61ed0bdd1b539934fbe84d5716aa9076d0091ac65f1c8aa8d765 SHA512 3d01fa3baae27bb179d3e27cbbce827324931e3c772465604019cef5f204db1f378e8a261cfdff82f561478d9e8592c9d151d43eed08a4a4ae9ea718054260bb
DIST plasma-thunderbolt-5.25.5.tar.xz 68828 BLAKE2B 2e43e20f1413b2edf502f5d7a7b766d956e5bae7f69b983f234546270c629148baf126415915360d8991292139c2d41c687df308d143e359c5a47343d35ddc29 SHA512 73280e422e30893f90586ff7248a6ec0db8d8b518a205187c550545381ee34b09fa648ce819129f8cf2823877f7fcdbbc8e3484a4ca86fa427b2c95915f532b7
EBUILD plasma-thunderbolt-5.24.6.ebuild 902 BLAKE2B d3db55ea334f743467b042f571840311536edefffecf00dcdd3e921655670117de845cf9a50007a1aad6e53f9b3187a3b6984e81c3ce769ac4a0a86e057ef4b7 SHA512 60ccc4aafad2a6bdd0e2ec9d08f5574c40106d8f8d6b2551dab9a4fe767bfc908af2c8679fa31c8c2fa5d38ecc3eac4ce7ddfa0e78505f2e25cbba7e45cab19c
+EBUILD plasma-thunderbolt-5.25.5-r1.ebuild 952 BLAKE2B 30b1999d8ae6b21efc3340f014f3efc64000808068e863fc2070eb340ba3992885191b382198784df0cab9700e5086967fd007d5424292dcda99f17cacc465ef SHA512 034483a2d34ea4a538ebdb33c9938d26d320e89e91f5f829a7ccda8e77784594e866c82373c28a5bc4072d319b9d21dc9dd7fbcdb78e0e4352db77de2124c00c
EBUILD plasma-thunderbolt-5.25.5.ebuild 902 BLAKE2B f05ab4de1a5f5f776dc20edbe10fda5899699aed9e5f8c9c9c5b17c19d051721d0ec5134bc129a2badb82a96a3fa7ecbf2121251c452430b2f174139a239b0c6 SHA512 88be42da79ea6e18746b0cb40fb77679c6a9e52bc4565af9f9a3881e453cefb229c9ff6be24175a9e34833689e9961fd167d5ac73e2ae37fec310fb5334eeefc
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch b/kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch
new file mode 100644
index 000000000000..f45edfa86f77
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/files/plasma-thunderbolt-5.25.5-kcm-crash.patch
@@ -0,0 +1,71 @@
+From 09c37c1c312991d08c10c7af94a83902150cb3ad Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Mon, 27 Jun 2022 16:46:08 +0100
+Subject: [PATCH] Avoid combining smart pointers and qobject parent ownership
+
+Devices are stored as QSharedPointer<Device> mDevices. If something has
+the memory managed explicitly we don't want QObject parents to also try
+and do the same job.
+
+BUG: 439192
+---
+ src/lib/device.cpp | 4 ++--
+ src/lib/device.h | 2 +-
+ src/lib/manager.cpp | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/lib/device.cpp b/src/lib/device.cpp
+index b79d029..94964be 100644
+--- a/src/lib/device.cpp
++++ b/src/lib/device.cpp
+@@ -45,10 +45,10 @@ Device::Device(const QDBusObjectPath &path, QObject *parent)
+
+ Device::~Device() = default;
+
+-QSharedPointer<Device> Device::create(const QDBusObjectPath &path, QObject *parent)
++QSharedPointer<Device> Device::create(const QDBusObjectPath &path)
+ {
+ try {
+- return QSharedPointer<Device>::create(path, parent);
++ return QSharedPointer<Device>::create(path);
+ } catch (const DBusException &e) {
+ qCWarning(log_libkbolt, "%s", e.what());
+ return {};
+diff --git a/src/lib/device.h b/src/lib/device.h
+index 9b7e0f0..d183b12 100644
+--- a/src/lib/device.h
++++ b/src/lib/device.h
+@@ -46,7 +46,7 @@ class KBOLT_EXPORT Device : public QObject, public QEnableSharedFromThis<Device>
+ friend class Manager;
+
+ public:
+- static QSharedPointer<Device> create(const QDBusObjectPath &path, QObject *parent = nullptr);
++ static QSharedPointer<Device> create(const QDBusObjectPath &path);
+ explicit Device(QObject *parent = nullptr);
+ ~Device() override;
+
+diff --git a/src/lib/manager.cpp b/src/lib/manager.cpp
+index 683c28c..99f1732 100644
+--- a/src/lib/manager.cpp
++++ b/src/lib/manager.cpp
+@@ -26,7 +26,7 @@ Manager::Manager(QObject *parent)
+ }
+
+ connect(mInterface.get(), &ManagerInterface::DeviceAdded, this, [this](const QDBusObjectPath &path) {
+- if (auto device = Device::create(path, this)) {
++ if (auto device = Device::create(path)) {
+ mDevices.push_back(device);
+ qCDebug(log_libkbolt,
+ "New Thunderbolt device %s (%s) added, status=%s",
+@@ -46,7 +46,7 @@ Manager::Manager(QObject *parent)
+
+ const auto devicePaths = mInterface->ListDevices().argumentAt<0>();
+ for (const auto &devicePath : devicePaths) {
+- if (auto device = Device::create(devicePath, this)) {
++ if (auto device = Device::create(devicePath)) {
+ qCDebug(log_libkbolt,
+ "Discovered Thunderbolt device %s (%s), status=%s",
+ qUtf8Printable(device->uid()),
+--
+GitLab
+
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild
new file mode 100644
index 000000000000..137f827fe9df
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.25.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.95.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ sys-apps/bolt
+"
+
+PATCHES=( "${FILESDIR}/${P}-kcm-crash.patch" )