summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild')
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild
new file mode 100644
index 000000000000..88642424e300
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-6.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ sys-apps/bolt
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"