summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-nm
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest2
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.15.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 6194f8a9cebd..64a7059c223a 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,3 +1,5 @@
DIST plasma-nm-5.14.5.tar.xz 721144 BLAKE2B f9537e742be74b50ffeecee007ef91d93d108b566cf081cb4d25bc4d62c98847a74e7e69ec01b2f10e4e75eac4bc75cef90a3a47ad5ad199cec9f20c31bdaf20 SHA512 54667ff01db16bfadc1663dcf51668aed4eabcb70c3903538044bb478aeb4625d27777df13867cdf03048b6575a540de5c7baaef9e2dc2c41f458d2800daba96
+DIST plasma-nm-5.15.0.tar.xz 771304 BLAKE2B 68fa17fa52244b2e2002c45a32b6e01e0335fde5eb2e41d70d64d7b9db72b257f0d6af1d0483e74bfe076c0beedb33c4f9a2ef8085dbaf3a588ead69196eee2d SHA512 4de7a60d6a0b6b67d5d26f0f21e969022b4b4785551a4894aa493c31b3ada8c3dd979b3131784c2ead0af9c5b09c5efee3e0b6ff18e75556927b2fbdb818b5a0
EBUILD plasma-nm-5.14.5.ebuild 1986 BLAKE2B 25c9a92a8fb9f565a1bba33fc7b9e4fe9e709377fd6a6ba5524bf31675f11fb8446acd30e59eae3d868f395ea3ab073938886e7d06737dc2ec8f767866fe0fc5 SHA512 cdb63ea84dc5327959ef97081ed9f2a19381b59c0597678b1cdbb0752a7a33a588b9349d0cf43a372e41b73b4e12149e87e485060f882d7805c6e509769470d5
+EBUILD plasma-nm-5.15.0.ebuild 1979 BLAKE2B b54453cc7e64c8ceae8291e24a105f8a5e8c9f2accc7994f8e4375fff1c17e52bfbb38eac35fe8f8a3aaa028dab8cf993d8bde2726d3a9aaa7a0b8394b2dbf1f SHA512 a22ddc50c44e306d86a34f4c0c424fcd9252aa08264b17a87edfc455458d45b18496b2395c85e233f782573bc7b1d0ceab44f1f9574c0768a84fdd3ae940391c
MISC metadata.xml 479 BLAKE2B 501f2ff581390f3119e9474e1aeafb45f2e13f3cf25650482f39ab38c7fb0e70ac006f269693ef546ef324730f302c454d27d79f0346e43b6f37583ccad1ca93 SHA512 69a8ce09c5a437814562c315dc7ac3142ac6c71906f37a6ea98e7b76fdd332362cfa76e823d0ee1ec920e92c8f7dda2a557071c758e9937886d7df78943b5689
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.15.0.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.15.0.ebuild
new file mode 100644
index 000000000000..2d896c53ed9b
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.15.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}