summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-browser-integration/plasma-browser-integration-6.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-browser-integration/plasma-browser-integration-6.0.2.ebuild')
-rw-r--r--kde-plasma/plasma-browser-integration/plasma-browser-integration-6.0.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/plasma-browser-integration/plasma-browser-integration-6.0.2.ebuild b/kde-plasma/plasma-browser-integration/plasma-browser-integration-6.0.2.ebuild
new file mode 100644
index 000000000000..4ba4cb854551
--- /dev/null
+++ b/kde-plasma/plasma-browser-integration/plasma-browser-integration-6.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Integrate Chrome/Firefox better into Plasma through browser extensions"
+HOMEPAGE+=" https://community.kde.org/Plasma/Browser_Integration"
+
+LICENSE="GPL-3+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kfilemetadata-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/purpose-${KFMIN}:6
+ >=kde-plasma/plasma-activities-${PVCUT}:6
+ >=kde-plasma/plasma-workspace-${PVCUT}:6
+"
+DEPEND="${RDEPEND}
+ >=kde-frameworks/krunner-${KFMIN}:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMOZILLA_DIR="${EPREFIX}/usr/$(get_libdir)/mozilla"
+ )
+
+ ecm_src_configure
+}