summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/layer-shell-qt')
-rw-r--r--kde-plasma/layer-shell-qt/Manifest2
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.26.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/Manifest b/kde-plasma/layer-shell-qt/Manifest
index a9581ccabb83..a2ae6d8c6476 100644
--- a/kde-plasma/layer-shell-qt/Manifest
+++ b/kde-plasma/layer-shell-qt/Manifest
@@ -1,3 +1,5 @@
DIST layer-shell-qt-5.25.5.tar.xz 18336 BLAKE2B 0656118af97213591dc79bdf5ef695c3d7e665d6391a51a8e6281a3092b25c716f036aff86e4523a6e2cdf0237a1872bcd1c79862e11da2e72cba7a703b67b36 SHA512 728c741dffff88b3ceea9459f8f3be6c1d6f3ef18039a31951f44169f7d439855c20ad7cd228b9393317231b5ccc33f77e0b49e2852790e4c06c993a834f0b64
+DIST layer-shell-qt-5.26.0.tar.xz 18308 BLAKE2B 1b107d53144fb97c82605aab1df023e3004f68e64a96f7d0b6151baa03ef046aa33d1ce3d86e61fe2488dc303a20070fe8d7fed6c0275d19b79648e0ff9e2e01 SHA512 5021fe21954538d44f2fc452931bd78a1443d1ac6d7f639645aca1f4ac068186680314edc07c2f1a84158ebb2ff44b1645eff61189e0a2be26cf4bdcd0df2d86
EBUILD layer-shell-qt-5.25.5.ebuild 826 BLAKE2B cec3fa6d3da7f9e032676a503ac8ac149d42898d42a9f588170bb251f4b0d1f42a6f15950b872854697741da481aeee4db9bb27a7be0e10a06c7cfd8214143fa SHA512 c4e70e7c7f532187babb17bf9134c2ca7020f19908f20809e4b5fb7d12197cd954febceeac2843ca3c35c4f56d7848ef3bf3db1249a52f1451e2011aff7faabb
+EBUILD layer-shell-qt-5.26.0.ebuild 791 BLAKE2B 9d075f3f125f76dbda3e2f0c810a4cbc1d3cd9877ecbadbe9007e6e7eb4219067060bc757523320d236e1899a03f6923906a2663c18e8e4b211d897ed592f57f SHA512 6e7cbfa2a85b7257dad6afe66bdfdb380f21bf39aa06c1cda5ef23320fe63bafe47ac9857b911d0e1f22f2dd33dff12a38751b60291a5002e3b6405878cc9c17
MISC metadata.xml 318 BLAKE2B 922a5e32e706b2976c5f359a14194d268d3f499398576c80ce5fad8c0fcea0fbf048de4480a80a6a1889c88b8b6c14147654a3ab4d5ffbcc258c2290da63f6d1 SHA512 614cb8dda7ad2088e5d6ef39b449bb4be0ac72cd0231c320188d76d1816dce6490c5114bb4798112c4b11d99d30a9e82ff8fcf08ffa8c049589682a5e38208f6
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.0.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.0.ebuild
new file mode 100644
index 000000000000..48646438b451
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.26.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"