summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-5.27.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-5.27.11.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.27.11.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.27.11.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.27.11.ebuild
new file mode 100644
index 000000000000..52d92c7a318c
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.27.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot op: various private QtWaylandClient headers
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"