summaryrefslogtreecommitdiff
path: root/kde-plasma/ksshaskpass
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest2
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.17.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 347546d48f00..2aa002ac2a58 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,4 +1,6 @@
AUX 05-ksshaskpass.sh 42 BLAKE2B 2fcef93ed56ab90d98078017924ccfcf3892914e0fc45c6733b538634743a79ae1603da4aabed1c9641750ceae24e167591989290427f6efa4a03b4d69008362 SHA512 780f4d0467bab82295f894f0547ea59c36e8f05cff51c4e64db8a7e8e4215e2d6363550fed16a4336019b2102e5c5bdcfe73524761ba04db3704ddec6efec669
DIST ksshaskpass-5.16.5.tar.xz 21416 BLAKE2B 832f4fcce536feea013ae3b71f1346e6dc6ddddc6036b000979d0860181a40f2eaf016c0ba59ac1fac929eabeed51a494fa55f8da062d58c27bf9cc711787f72 SHA512 b2ca1245ca55fce2fdd722b5b318bf137efffb9d6ee8ece30706cc369b51e1943f738cd95be29a01fd74e184175f4ce0d6fefdc58a2a621d80358dbfe293cfb9
+DIST ksshaskpass-5.17.2.tar.xz 21500 BLAKE2B 964633fa8d75f09a6022c927bc68d8dda7da7b803b97eed8134dde528b7e4e9f9c1c930f8a1ffa37baccae6c796188a3e5204ed3e4b230f3c4ae7f610814182a SHA512 8f3d981a2098426f1e4a23e9caa229eae176bcd236012c8e97a58249970c4ed92496d6d5c65fc95e40e2d9254911fce637710fb317a74613c0b0b0c97f902c1a
EBUILD ksshaskpass-5.16.5.ebuild 1208 BLAKE2B ea2987af04a4d3f03040a66a782090fd7e6be7194b30bb9dadaf2f0bb01e95b12616efa562563f4171ebbb9489828a37dc44416b394b5d242e1c17ec77d4b43b SHA512 a1cddc2234d04f3df3ad15f81c50e2935c752e9913d69da6b0bb6e0c7a1c6319bc63031a33c183d7b66456fc628fd62f166b020db34562aa1ea6ebedb0012306
+EBUILD ksshaskpass-5.17.2.ebuild 1415 BLAKE2B c092c49b675c81660d67406a56f453c2a4bd5418f76fd6f77893f865493f27f98c3af12d7e5e16061eeb1e9cde7db6be069953691efd4645938e77052aa8d2af SHA512 392ee95f8046631f19140e516f0fce5f26fec58905c331efe58753a4af61d7b6d572ed51f38d90408966b13ae7d4167c66d3b5400c9bbf6ab1d397adec03348b
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.17.2.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.17.2.ebuild
new file mode 100644
index 000000000000..9e6cbd72bddd
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.17.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh (ATTN: Path moved!)"
+ elog
+ elog "In order to have ssh-agent start with Plasma 5, do the following:"
+ elog " * Copy the necessary files to your home directory:"
+ elog " - cp /etc/plasma/startup/10-agent-startup.sh ~/.config/plasma-workspace/env/"
+ elog " - cp /etc/plasma/shutdown/10-agent-shutdown.sh ~/.config/plasma-workspace/shutdown/"
+ elog " * Edit 10-agent-startup.sh and uncomment the lines enabling ssh-agent."
+ elog " * In 10-agent-shutdown.sh uncomment the respective lines to properly kill"
+ elog " the agent when the session ends."
+}