summaryrefslogtreecommitdiff
path: root/kde-plasma/kde-gtk-config/kde-gtk-config-6.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kde-gtk-config/kde-gtk-config-6.0.2.ebuild')
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-6.0.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-6.0.2.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-6.0.2.ebuild
new file mode 100644
index 000000000000..ebbb0c9ae074
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-6.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Syncs KDE Plasma theme settings to GTK applications"
+HOMEPAGE="https://invent.kde.org/plasma/kde-gtk-config"
+
+LICENSE="GPL-3"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtsvg-${QTMIN}:6
+ gnome-base/gsettings-desktop-schemas
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-plasma/kdecoration-${PVCUT}:6
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}
+ >=kde-plasma/kde-cli-tools-${PVCUT}:*
+ x11-misc/xsettingsd
+"
+BDEPEND="dev-lang/sassc"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+}