summaryrefslogtreecommitdiff
path: root/kde-plasma/breeze-gtk/breeze-gtk-6.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/breeze-gtk/breeze-gtk-6.0.2.ebuild')
-rw-r--r--kde-plasma/breeze-gtk/breeze-gtk-6.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-plasma/breeze-gtk/breeze-gtk-6.0.2.ebuild b/kde-plasma/breeze-gtk/breeze-gtk-6.0.2.ebuild
new file mode 100644
index 000000000000..3864c459aa31
--- /dev/null
+++ b/kde-plasma/breeze-gtk/breeze-gtk-6.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+PYTHON_COMPAT=( python3_{10..12} )
+inherit ecm plasma.kde.org python-any-r1
+
+DESCRIPTION="Official GTK+ port of Plasma's Breeze widget style"
+HOMEPAGE="https://invent.kde.org/plasma/breeze-gtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/sassc
+ $(python_gen_any_dep 'dev-python/pycairo[${PYTHON_USEDEP}]')
+ >=kde-plasma/breeze-${PVCUT}:6
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pycairo[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ ecm_pkg_setup
+}