summaryrefslogtreecommitdiff
path: root/kde-misc/kwebkitpart/kwebkitpart-1.4.0_pre20180302.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kwebkitpart/kwebkitpart-1.4.0_pre20180302.ebuild')
-rw-r--r--kde-misc/kwebkitpart/kwebkitpart-1.4.0_pre20180302.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-misc/kwebkitpart/kwebkitpart-1.4.0_pre20180302.ebuild b/kde-misc/kwebkitpart/kwebkitpart-1.4.0_pre20180302.ebuild
new file mode 100644
index 000000000000..59e7b3b79595
--- /dev/null
+++ b/kde-misc/kwebkitpart/kwebkitpart-1.4.0_pre20180302.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT="cca571d4316b636029a26dcb710fad705fa63ed4"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="WebKit KPart for Konqueror"
+HOMEPAGE="https://cgit.kde.org/kwebkitpart.git"
+SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-misc/kwebkitpart:4
+"