summaryrefslogtreecommitdiff
path: root/kde-misc/kweather/kweather-24.02.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kweather/kweather-24.02.2.ebuild')
-rw-r--r--kde-misc/kweather/kweather-24.02.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-misc/kweather/kweather-24.02.2.ebuild b/kde-misc/kweather/kweather-24.02.2.ebuild
new file mode 100644
index 000000000000..b0bf19607286
--- /dev/null
+++ b/kde-misc/kweather/kweather-24.02.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="utilities"
+ECM_TEST="false"
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Weather forecast application for Plasma with flat and dynamic/animated views"
+HOMEPAGE="https://apps.kde.org/kweather/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/kirigami-addons:6
+ dev-libs/kweathercore:6
+ >=dev-qt/qtbase-${QTMIN}:6[gui,network,opengl,widgets]
+ >=dev-qt/qtcharts-${QTMIN}:6[qml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kholidays-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ kde-plasma/libplasma:6
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qt5compat-${QTMIN}:6[qml]
+ >=dev-qt/qtpositioning-${QTMIN}:6[geoclue]
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ sed -e "/include(ECMCheckOutboundLicense)/s/^/#DONT /" \
+ -e "/ecm_check_outbound_license/s/^/#DONT /" \
+ -i CMakeLists.txt || die # avoid cmake spam about python, reusetool
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PLASMOID=ON
+ )
+ ecm_src_configure
+}