summaryrefslogtreecommitdiff
path: root/kde-misc/gmailfeed/gmailfeed-1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/gmailfeed/gmailfeed-1.1-r1.ebuild')
-rw-r--r--kde-misc/gmailfeed/gmailfeed-1.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-misc/gmailfeed/gmailfeed-1.1-r1.ebuild b/kde-misc/gmailfeed/gmailfeed-1.1-r1.ebuild
new file mode 100644
index 000000000000..ee9be6ee7d52
--- /dev/null
+++ b/kde-misc/gmailfeed/gmailfeed-1.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QT_MINIMAL=5.12.1
+inherit kde5
+
+DESCRIPTION="Plasma 5 applet providing a list of unread emails from your Gmail inbox"
+HOMEPAGE="https://store.kde.org/p/998911/ https://github.com/anthon38/gmailfeed"
+SRC_URI="https://github.com/anthon38/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxmlpatterns 'qml(+)' 5.12.1-r1)
+"
+RDEPEND="${DEPEND}
+ $(add_qt_dep qtquickcontrols)
+"