summaryrefslogtreecommitdiff
path: root/kde-frameworks/syntax-highlighting/syntax-highlighting-5.115.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/syntax-highlighting/syntax-highlighting-5.115.0-r1.ebuild')
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.115.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.115.0-r1.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.115.0-r1.ebuild
new file mode 100644
index 000000000000..93a2dfd1f115
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.115.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5"
+BDEPEND="
+ dev-lang/perl
+ >=dev-qt/linguist-tools-${QTMIN}:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" ) # bug 924756