summaryrefslogtreecommitdiff
path: root/kde-frameworks/purpose/purpose-5.246.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/purpose/purpose-5.246.0.ebuild')
-rw-r--r--kde-frameworks/purpose/purpose-5.246.0.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/purpose-5.246.0.ebuild b/kde-frameworks/purpose/purpose-5.246.0.ebuild
new file mode 100644
index 000000000000..4d859686c01c
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.246.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="bluetooth"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/prison-${PVCUT}*:6
+"
+# kaccounts? (
+# >=kde-apps/kaccounts-integration-19.04.3:6
+# net-libs/accounts-qt
+# )
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+ >=kde-frameworks/kdeclarative-${PVCUT}:6
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
+"
+# kaccounts? ( net-libs/accounts-qml )
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+# src_configure() {
+# local mycmakeargs=(
+# $(cmake_use_find_package kaccounts KAccounts)
+# )
+#
+# ecm_src_configure
+# }
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}