summaryrefslogtreecommitdiff
path: root/kde-frameworks/plasma
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/Manifest6
-rw-r--r--kde-frameworks/plasma/plasma-5.64.0.ebuild10
-rw-r--r--kde-frameworks/plasma/plasma-5.66.0.ebuild (renamed from kde-frameworks/plasma/plasma-5.65.0.ebuild)41
3 files changed, 29 insertions, 28 deletions
diff --git a/kde-frameworks/plasma/Manifest b/kde-frameworks/plasma/Manifest
index 9cb0c41a30e1..b5e2a3502a41 100644
--- a/kde-frameworks/plasma/Manifest
+++ b/kde-frameworks/plasma/Manifest
@@ -1,5 +1,5 @@
DIST plasma-framework-5.64.0.tar.xz 3120788 BLAKE2B c9c008e4b4b711ba4c370ba95029c4fc7392fe298057f5f8fe959118ad873325cfef3e3a93cee0dc73c7ce786287f18ab661f22e9f32c5f706aca5d15b70d24a SHA512 d0dcdbc4c537d064a125cef11d07e562a9a3b1bd83442217f8f435260420753c34b4dfddd733fc497533bf16a22fad3746884764395e07cf0f268d5f8435ef3c
-DIST plasma-framework-5.65.0.tar.xz 3123308 BLAKE2B a3094aeb3f5282b485b71d55353ac1f7b986567d48256dae785e55ce5f631a386fce2b47f56b20eaaccd82307437936b9a19ae08abd8f0ff6656cd80bf0fe003 SHA512 a8b3cd9921b759631d717af365ef64e34a9b00db9237a4c2f4006a15bcf12c3f34f4d19bef8b50aaaa7e47ceb8055617cfb0a1e76783d9287f03127df1241f85
-EBUILD plasma-5.64.0.ebuild 1929 BLAKE2B 1b4a599ce4b77f0b758f095b7e894b670c3da10bdb46c65f5d90522bfca6d4f5f543fa163777a184331068ca4eca687c72ce8150aa4070672b4ecbb412d250dd SHA512 4cfda76a5a2e35df8346a1d05fdbda4b87b13922ed6d5811c54e68e3443b698529e09e4599e61ffd1542724888797d350e592e5018a617f0b4908e97abbc23c7
-EBUILD plasma-5.65.0.ebuild 1902 BLAKE2B 1ccf6830954733844595f3aa959614ba354497ce461261091b320d493aeccbe4cd2dde56b2d0ae0b49b6766e22747d80f2ea510c548ef826d269db0d47fb47ee SHA512 244f0d35ded52a227dd96c6acf5d09b236792cfb73ed0267218cc09389f58fd70531cb6d8ac4c518261e0a5b02b93e10fb420980cda4eb2bdaeb9153ad9b9a3d
+DIST plasma-framework-5.66.0.tar.xz 3124284 BLAKE2B e62675e9880ef0a87c680a7619ce5a4177b27154f2a3c70f788bd436ba1a09924244c138561d53683c02f1aae99cb5f211199e2648203789fdaa97fa8841fc21 SHA512 b6a192e19e4cf4e9172aa3ac6697f58a6d3b198885929c2fd0da0732743153ee17d3d489328b2bffc7f48f5674369c20a025c4ef47aae10a0b50d03a660a7822
+EBUILD plasma-5.64.0.ebuild 1899 BLAKE2B e63ebf02875b1bcafe8fcdc4a808b825bf9308c9beb389c9a1f748d04df385740f57fc76a4c87108ba1e8ae9162a557847eedd882336170aade350139bef13d9 SHA512 30dfcde51067155c381cc15f58d182fcb4dbe121ecc9fc8cd0b277cd6c74ed1807b051a64e485bc681a9ec5471576dd9c63819bd535389ed72d1686655784c73
+EBUILD plasma-5.66.0.ebuild 1903 BLAKE2B ff4ad330cac1e5e1a53f5608ece4cfe47d8be360a438572f6aeb8fc4e8e2e0f3b2d1202859cf17a53856b2a7faaaa3b90c93d3581443d1ce686bbf77aa136a9b SHA512 a0f81672895f3327c94235f787592ba3a463a0e151e710cf37a9ac3cae2ecc6ad7af1f373d2b70c91ccb9fac7b3d750b117afb9a9a9a9dc6844a65ee73203546
MISC metadata.xml 337 BLAKE2B 83b14f1456a141498367a54d2b3b1bd22095d8a2ea5d4b348bcc1b27b6e753900e89d2b2f7f6623a9737c6c6fdf4fdc741fb38fef17b17bc458d182e72be919c SHA512 bd0bffaf1b63f9b0181776335e38b2ad44baef7fd4a1d78752b5e342de444bfcda03b72c795c0b52c87a768e243e9ffdfbd02de745c2dde8f8372fdcfbaf2797
diff --git a/kde-frameworks/plasma/plasma-5.64.0.ebuild b/kde-frameworks/plasma/plasma-5.64.0.ebuild
index 0d3c7980ecd0..41d92a57f3e8 100644
--- a/kde-frameworks/plasma/plasma-5.64.0.ebuild
+++ b/kde-frameworks/plasma/plasma-5.64.0.ebuild
@@ -63,11 +63,11 @@ RESTRICT+=" test"
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_find_package !gles2 OpenGL)
- $(cmake-utils_use_find_package wayland EGL)
- $(cmake-utils_use_find_package wayland KF5Wayland)
- $(cmake-utils_use_find_package X X11)
- $(cmake-utils_use_find_package X XCB)
+ $(cmake_use_find_package !gles2 OpenGL)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ $(cmake_use_find_package X XCB)
)
ecm_src_configure
diff --git a/kde-frameworks/plasma/plasma-5.65.0.ebuild b/kde-frameworks/plasma/plasma-5.66.0.ebuild
index 2738194ffcea..55e56d29cd5a 100644
--- a/kde-frameworks/plasma/plasma-5.65.0.ebuild
+++ b/kde-frameworks/plasma/plasma-5.66.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,6 +10,7 @@ VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Plasma framework"
+
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="gles2 wayland X"
@@ -19,24 +20,6 @@ BDEPEND="
>=kde-frameworks/kdoctools-${PVCUT}:5
"
RDEPEND="
- >=kde-frameworks/kactivities-${PVCUT}:5
- >=kde-frameworks/karchive-${PVCUT}:5
- >=kde-frameworks/kconfig-${PVCUT}:5
- >=kde-frameworks/kconfigwidgets-${PVCUT}:5
- >=kde-frameworks/kcoreaddons-${PVCUT}:5
- >=kde-frameworks/kdeclarative-${PVCUT}:5
- >=kde-frameworks/kglobalaccel-${PVCUT}:5
- >=kde-frameworks/kguiaddons-${PVCUT}:5
- >=kde-frameworks/ki18n-${PVCUT}:5
- >=kde-frameworks/kiconthemes-${PVCUT}:5
- >=kde-frameworks/kio-${PVCUT}:5
- >=kde-frameworks/kirigami-${PVCUT}:5
- >=kde-frameworks/knotifications-${PVCUT}:5
- >=kde-frameworks/kpackage-${PVCUT}:5
- >=kde-frameworks/kservice-${PVCUT}:5
- >=kde-frameworks/kwidgetsaddons-${PVCUT}:5
- >=kde-frameworks/kwindowsystem-${PVCUT}:5
- >=kde-frameworks/kxmlgui-${PVCUT}:5
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtdeclarative-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5=[gles2=]
@@ -44,9 +27,27 @@ RDEPEND="
>=dev-qt/qtsql-${QTMIN}:5
>=dev-qt/qtsvg-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
!gles2? ( virtual/opengl )
wayland? (
- >=kde-frameworks/kwayland-${PVCUT}:5
+ =kde-frameworks/kwayland-${PVCUT}*:5
media-libs/mesa[egl]
)
X? (