summaryrefslogtreecommitdiff
path: root/kde-frameworks/kwallet/kwallet-6.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kwallet/kwallet-6.1.0.ebuild')
-rw-r--r--kde-frameworks/kwallet/kwallet-6.1.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-frameworks/kwallet/kwallet-6.1.0.ebuild b/kde-frameworks/kwallet/kwallet-6.1.0.ebuild
new file mode 100644
index 000000000000..e323d4c64db2
--- /dev/null
+++ b/kde-frameworks/kwallet/kwallet-6.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org optfeature
+
+DESCRIPTION="Framework providing desktop-wide storage for passwords"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE="gpg +man"
+
+DEPEND="
+ >=app-crypt/qca-2.3.1:2[qt6(-)]
+ dev-libs/libgcrypt:0=
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/kdbusaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+ =kde-frameworks/kwindowsystem-${PVCUT}*:6[X]
+ gpg? ( app-crypt/gpgme:=[qt6(-)] )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:6 )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package gpg Gpgmepp)
+ $(cmake_use_find_package man KF6DocTools)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Auto-unlocking after account login" "kde-plasma/kwallet-pam:6"
+ optfeature "KWallet management" "kde-apps/kwalletmanager:6"
+ elog "For more information, read https://wiki.gentoo.org/wiki/KDE#KWallet"
+ fi
+ ecm_pkg_postinst
+}