summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcrash/kcrash-6.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-6.1.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-6.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-6.1.0.ebuild b/kde-frameworks/kcrash/kcrash-6.1.0.ebuild
new file mode 100644
index 000000000000..66b242efadce
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-6.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE="X"
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ test? ( >=dev-qt/qtbase-${QTMIN}:6[widgets] )
+"
+BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_X11=$(usex X)
+ )
+ ecm_src_configure
+}