summaryrefslogtreecommitdiff
path: root/kde-frameworks/kcmutils/kcmutils-6.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcmutils/kcmutils-6.1.0.ebuild')
-rw-r--r--kde-frameworks/kcmutils/kcmutils-6.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/kcmutils/kcmutils-6.1.0.ebuild b/kde-frameworks/kcmutils/kcmutils-6.1.0.ebuild
new file mode 100644
index 000000000000..3fedf3df984f
--- /dev/null
+++ b/kde-frameworks/kcmutils/kcmutils-6.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to work with KDE System Settings modules"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/kguiaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kitemviews-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+ =kde-frameworks/kxmlgui-${PVCUT}*:6
+"
+RDEPEND="${DEPEND}"